[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Denemo-devel] Showing lilypond text editing window

From: Richard Shann
Subject: Re: [Denemo-devel] Showing lilypond text editing window
Date: Tue, 16 Sep 2008 09:20:09 +0100

On Mon, 2008-09-15 at 23:33 -0600, Neil Johnson wrote:
> Hi all,
> I am running denemo on a Ubuntu machine, and it is a great
> program...exactly what I've been looking for for years now.  I've done
> some entry into denemo, and found that things work as expected most of
> the time.  However, occasionally, there are errors in the lilypond
> output.  I read in the docs that there is supposed to be a lilypond
> text editing window that is accessible in the View menu...well, it
> doesn't exist on my machine.  I went ahead and grabbed the source and
> got it compiling.  I looked in view.c and sure enough, there's a
> callback function for "toggle_lilytext", but it doesn't call
> anything...
??surely, you are not saying it looks like this: 

 *  Function to toggle the visibility of the LilyPond text window. It refreshes 
 *  the text if needed
static void
toggle_lilytext (GtkAction * action, gpointer param) {}

???There is a body to this function in the source code - essentially it


which shows/hides the lilypond text.

> and the menu item doesn't even appear in my menu. 
>  Am I
> missing something?  I'm using version 0.7.9 (my current compiled
> version from git) and I've also installed the binary for version
> 0.7.8.  The same thing happens in both.  Is this distro-specific?
It is difficult to imagine what could be happening. What messages are
you getting in the terminal window when you launch Denemo? There will be
some (spurious) messages about the LilyPond actions, which I hope to get
rid of for the next release, but I would expect to see more of the kind.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]