[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Denemo-devel] Release 0.8.16 - Gub Status

From: Nils Gey
Subject: Re: [Denemo-devel] Release 0.8.16 - Gub Status
Date: Tue, 23 Mar 2010 21:40:31 +0100

> Actually the push failed, and I will delay while further investigations
> take place
> Richard

Investigation Complete:

I finally got all lilypond enviroment variables right to run lilypond 
standalone and produce a valid pdf file. 
We need to copy this in Denemo.

...\denemo\usr\share\lilypond\current\scm //if we build lilypond git, its 




this last one is actually not needed, but may be nice for future testing.

Problems remain, two are just to inform you, the third is the real one:

1)PDFs show up from where path\to\lilypond.exe was invoked. Means: The current 
working dir.

2)Running lilypond from the command line has problems. Maybe backslash\
escaping problems. 
janneke: "and no-one uses the command line, apparently ;-)"

If you place the .ly file to the dir in %PATH% it works. And it works, if you 
do it with a file association, that means the console it the reason that it 
does not work (thats why I think its some escaping problem)

BUT (good news) from within Denemo these last two problems are no problems. The 
file gets generated and ends in the right place. 

3)However the ly/pdf file does not gets processed until Denemo is closed. Don't 
ask me, I don't know why...
You see the lilypond terminal open all the time, but nothing happens, and if 
you quit Denemo the processing begins and the pdf is right there.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]