[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Denemo-devel] [bug #29523] Copy-paste issues.

From: anonymous
Subject: [Denemo-devel] [bug #29523] Copy-paste issues.
Date: Mon, 12 Apr 2010 04:04:49 +0000
User-agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv: Gecko/20100401 Firefox/3.6.3 (.NET CLR 3.5.30729)


                 Summary: Copy-paste issues.
                 Project: GNU Denemo, a gtk+ frontend to GNU Lilypond
            Submitted by: None
            Submitted on: Mon 12 Apr 2010 04:04:48 AM UTC
                Category: None
                Severity: 3 - Normal
              Item Group: None
                  Status: None
                 Privacy: Public
             Assigned to: None
             Open/Closed: Open
         Discussion Lock: Any



The copying has some irregularities that make scripting hasslesome.

#1.  Enter c & e quarters.  Copy the C to the clipboard.  Now try to paste it
between the c & e.  The cursor winds up AFTER the e instead of after the
second c/BEFORE the e (even if the cursor appears ON the e, that would be
fine).  This is a problem when trying to paste several things in a row. 
Because when there's something after the spot you paste, you need to cursor
left.  When there's NOTHING following in the measure, you must not cursor left
or you'll end up pasting in behind the one you just did.  I'm trying to finish
up a Rebar script and that's how I ran into this.

#2.  Try to select one note with the keyboard shift - Left or right.
->Denemo selects two notes.
Yeah, you can back up to get just one, but it's not ideal.  More of a UI
issue than scripting.

Not sure what would be the fix for pasting.
-Dan W.


Reply to this item at:


  Message sent via/by Savannah

reply via email to

[Prev in Thread] Current Thread [Next in Thread]