[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Denemo-devel] Re:

From: Richard Shann
Subject: [Denemo-devel] Re:
Date: Tue, 28 Sep 2010 12:57:47 +0100

On Mon, 2010-09-27 at 19:51 +0200, Nils Gey wrote:
> Denemo fails to import mytestl.y correctly.
yes, this is certain. \relative is ignored so notes will get into the
wrong octave in general. \repeat is ignored and \alternative, so all
those bars will just be entered one after the other.
That example has two voices per staff: these are handled but I am not
sure that the durations for the syntax R, s and r (whole measure rests,
non-printing rests (skips) and rests respectively) are handled properly.
I frankly *cannot* understand the LilyPond manual on the notation for
durations: under rest durations it refers you to note durations, but
note durations immediately goes off to notation for ties for durations
that can't be a single note, so it ends up that nowhere is the syntax
properly explained (AFAIK). The C++ actions in the parser are pretty
impenetrable too.

So, all this stuff about \repeat, \relative and duration handling is to
be done.

> It does the importing loop but I see that not all notes are imported, right 
> from the start. For example the second voice is missing and the first note in 
> in this wrong octave relative to the second and all other notes alltogether 
> are in the wrong octave. The lilypond error desribed later also is there when 
> converting from Denemo->PDF.
> Running guile lyimport.scm and copying the scheme output to Denemos scheme 
> window creates a similar result. I did not check on the details but at least 
> the start is the same. Missing voice, wrong octaves.
> However, even Lilypond 2.12.3 which is installed on my system fails somehow. 
> BUT the pdf looks much better than Denemos import result, I would say it 
> looks correct. 
> LANG=ENG lilypond 
> GNU LilyPond 2.12.3
> Processing `'
> Parsing...
> error: program too old: 2.12.3 (file requires: 2.13.4)
> error: unknown escaped string: `\Scoreh'
>     \context { 
>                \Scoreh        autoBeaming = ##f

I have seen this too. Obviously a wrong LilyPond version problem.

What I cannot understand is getting different results loading
from within denemo and from the standalone guile execution of
Do you see this?


> error: syntax error, unexpected STRING, expecting '='
>     \context { \Scoreh        
>                               autoBeaming = ##f
> error: syntax error, unexpected '}'
>     }
> Interpreting music... [8][16][24][32][40][48][56][64][72][80][88]
> warning: cannot end volta spanner
> Preprocessing graphical objects...
> Finding the ideal number of pages...
> Fitting music on 3 or 4 pages...
> Drawing systems...
> Layout output to `'...
> Converting to `./mytest.pdf'...
> error: failed files: ""

reply via email to

[Prev in Thread] Current Thread [Next in Thread]