[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Denemo-devel] PDF window

From: Jeremiah Benham
Subject: Re: [Denemo-devel] PDF window
Date: Sat, 22 Oct 2011 15:47:40 -0500
User-agent: Mozilla/5.0 (X11; Linux i686; rv:7.0.1) Gecko/20110929 Thunderbird/7.0.1

On 10/22/2011 11:39 AM, Richard Shann wrote:
On Sat, 2011-10-22 at 07:53 -0500, Jeremiah Benham wrote:
On 10/22/2011 03:05 AM, Richard Shann wrote:
checking for EVINCE... no
configure: error: Package requirements (evince-view-2.3>= 2.3) were

No package 'evince-view-2.3' found
I edited It should work for you now. Let me know.
Right that is working fine now. It builds and the point and click is
working - some minor niggles with it re-lilyponding when it doesn't need
to, which I am fixing.
  Can we make it the default to use evince now then (so --disable-evince
would be needed if no libevince package was available)?

It will not compile for ubuntu users, debian sid, and probably other distro's because they use libevince-3 only (no libevince 2.30 on ubuntu). We are unable to compile with evince-3.0 or above at this time because it depends on gtk-3. I tried this already. I think we should wait until we begin migrating to gtk-3. We will have to maintain gtk-2 and evince-2.30 support until gtk-3 and evince-3 is available in debian stable. Once we have denemo able compile with gtk-3 and evince-3.0 we can provide a switch like ./configure --with-gtk3 (if we can't have ./configure determine this itself). Sorry long story short...I don't think we are ready. I hope this email makes sense. I have been interrupted about five times for each sentence written.



reply via email to

[Prev in Thread] Current Thread [Next in Thread]