[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Discuss-gnuradio] Compiling local programs, again

From: Ricky Hussmann
Subject: [Discuss-gnuradio] Compiling local programs, again
Date: Wed, 30 Jul 2003 14:22:34 -0400
User-agent: KMail/1.5

Hello all,

        I hate to bring up the issue of compiling local programs again, but I'm 
working on a demodulator module and I need to compile it. I've checked to 
make sure I have the correct versions of everything. Here's my setup:

autoconf: 2.57
automake: 1.7.6
libtool: 1.5
swig: 1.3.19

According to Eric's email this should meet all the required specs. I've added 
the file I'm creating to the GENERATED_H list in src/gnu/lib/gr/Makefile.am 
(I packed all the code into the .h file, no .cc file) Then, I descended to 
the main gnuradio directory and tried ./configure --enable-maintainer-mode. 
While running the configure I get

./configure: line 1824: LF_CONFIGURE_CC: command not found
./configure: line 1825: LF_CONFIGURE_CXX: command not found
./configure: line 1826: LF_SET_WARNINGS: command not found
./configure: line 1827: GR_SET_GPROF: command not found
./configure: line 1828: GR_SET_PROF: command not found
./configure: line 1829: GR_PROG_AS: command not found

./configure: line 5823: GR_CHECK_DOXYGEN: command not found
./configure: line 5824: GR_SET_MD_CPU: command not found
./configure: line 5825: GR_CHECK_MC4020: command not found

But configure seems to make it out alive. However, the following make command 
is not so lucky...

make[4]: Entering directory 
Makefile:246: *** missing separator.  Stop.

I'm positive I've never changed the Makefile.* in the cppunit directory, so I 
have no idea where this comes from.

That didn't work so I ran bootstrap. This is what I got from it:

src/gnu/lib/Makefile.am:28: Libtool library used but `LIBTOOL' is undefined
src/gnu/lib/Makefile.am:28: The usual way to define `LIBTOOL' is to add 
src/gnu/lib/Makefile.am:28: to `configure.ac' and run `aclocal' and `autoconf' 
src/gnu/lib/dtv/Makefile.am:29: Libtool library used but `LIBTOOL' is 
src/gnu/lib/dtv/Makefile.am:29: The usual way to define `LIBTOOL' is to add 
src/gnu/lib/dtv/Makefile.am:29: to `configure.ac' and run `aclocal' and 
`autoconf' again.
src/gnu/lib/gr/Makefile.am:203: MD_CPU_generic does not appear in 
src/gnu/lib/gr/Makefile.am:207: MD_CPU_x86 does not appear in AM_CONDITIONAL
src/gnu/lib/gr/Makefile.am:23: Libtool library used but `LIBTOOL' is undefined

This continues for many of the Makefile.am's in the source tree. Also, the 
following lines pop up as well...

configure.ac:58: error: possibly undefined macro: AC_DISABLE_SHARED
      If this token and others are legitimate, please use m4_pattern_allow.
      See the Autoconf documentation.
configure.ac:59: error: possibly undefined macro: AC_PROG_LIBTOOL
aclocal: configure.in: 52: macro `AM_PROG_LIBTOOL' not found in library
configure.in:38: version mismatch.  This is Automake 1.7.6,
configure.in:38: but the definition used by this AM_INIT_AUTOMAKE
configure.in:38: comes from Automake 1.4-p6.  You should recreate
configure.in:38: aclocal.m4 with aclocal and run automake again.
/usr/local/share/automake-1.7/am/depend2.am: am__fastdepCXX does not appear in 
/usr/local/share/automake-1.7/am/depend2.am: AMDEP does not appear in 
/usr/local/share/automake-1.7/am/depend2.am: am__fastdepCXX does not appear in 
/usr/local/share/automake-1.7/am/depend2.am: AMDEP does not appear in 

After the bootstrap, ./configure --enable-maintainer-mode doesn't complain 
nearly as much, but the make command fails with the same errors. Can anyone 
help out with this?

Thanks in advance,
Ricky Hussmann

reply via email to

[Prev in Thread] Current Thread [Next in Thread]