[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Discuss-gnuradio] scopesink.py crashes, Mac OS X, wxPython

From: Jonathan Jacky
Subject: [Discuss-gnuradio] scopesink.py crashes, Mac OS X, wxPython
Date: Fri, 14 Jan 2005 13:36:05 -0800 (PST)

I have built gnuradio-core, gnuradio-examples, and gr-wxgui on Mac OS X.
I also installed wxPython (, numarray (1.1.1) and Numeric (23.7).

When I try "pythonw scopesink" it does display the scope with a sinewave
trace on it.  But then the scope window freezes; it is unresponsive to
input (even to close it).  The wxPython stdout/stderr window displays
a traceback (shown below).

After the gnuradio-core installation, "make check" reported one error:
 .... gr_vmcircbuf_sysv_shm_factory: Failed
All the other checks passed.

I've run a few of the demos in the wxPython distribution; they seem to
work OK.

scopesink.py has "import Numeric".  I also tried running with
numarray by replacing this with "import numarray as Numeric". It failed in exactly the same way.

I also tried the other demos in wxgui. waterfallsink.py displays a blank window and freezes --- the stdout/stderr window does not
appear.  fftsink also draws a blank window and freezes.  There is a
stdout/stderr window below it, but I can't read it because it is
covered by the blank window, which can't be moved.

Any suggestions?

- Jon Jacky

Here is the traceback from "pythonw scopesink.py":

Traceback (most recent call last):
  File "/usr/local/lib/python2.3/site-packages/gnuradio/wxgui/plot.py",
   line 896, in OnSize
  File "/usr/local/lib/python2.3/site-packages/gnuradio/wxgui/plot.py",
   line 825, in Clear
    dc = wx.BufferedDC(wx.ClientDC(self), self._Buffer)
  File "//Library/Python/2.3/wx-2.5.3-mac-ansi/wx/_gdi.py",
   line 3909, in __init__
    newobj = _gdi_.new_BufferedDC(*args)
wx._core.PyAssertionError: C++ assertion "m_buffer.Ok()"
 failed in /BUILD/wxPython-src-
  invalid bitmap in wxBufferedDC

Traceback (most recent call last):
  File "scopesink.py", line 359, in format_data
    npoints = len (records[0])
IndexError: list index out of range
... (previous four lines repeat 10 times)

Exception in thread Thread-1:
Traceback (most recent call last):
  File "/System/Library/Frameworks/Python.framework/Versions/2.3/lib/python2.3/
          threading.py", line 436, in __bootstrap
  File "scopesink.py", line 155, in run
    for ch in range (nchan):

reply via email to

[Prev in Thread] Current Thread [Next in Thread]