[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Discuss-gnuradio] Building on Fedora Core 3 x86_64?

From: Eric Blossom
Subject: Re: [Discuss-gnuradio] Building on Fedora Core 3 x86_64?
Date: Fri, 18 Feb 2005 13:28:56 -0800
User-agent: Mutt/1.5.6i

On Fri, Feb 18, 2005 at 07:45:17AM -0500, Graham Stead wrote:
> Hi Everyone,
> I'm new to this and am just learning my way around.
> I tried building gnuradio-core 2.4 on 64-bit Fedora Core 3. When linking
> with libfftw3f (which I also downloaded, compiled and installed), I received
> the following error:
> ---
> g++ -shared -nostdlib
> /usr/lib/gcc/x86_64-redhat-linux/3.4.2/../../../../lib64/crti.o
> /usr/lib/gcc/
> x86_64-redhat-linux/3.4.2/crtbeginS.o  .libs/bug_work_around_6.o
> -Wl,--whole-archive
> filter/.libs/libfilter.a g72x/.libs/libccitt.a general/.libs/libgeneral.a
> io/.libs/libio.a missing/.libs/
> libmissing.a omnithread/.libs/libomnithread.a reed-solomon/.libs/librs.a
> runtime/.libs/libruntime.a
> /usr/local/lib/libfftw3f.a -Wl,--no-whole-archive  -Wl,--rpath
> -Wl,/usr/local/lib -Wl,--rpath
> -Wl,/usr/local/lib -pthread -lrt -L/usr/local/lib
> /usr/local/lib/libcppunit.so -ldl -L/usr/lib/gcc/
> x86_64-redhat-linux/3.4.2
> -L/usr/lib/gcc/x86_64-redhat-linux/3.4.2/../../../../lib64 -L/usr/lib/
> gcc/x86_64-redhat-linux/3.4.2/../../.. -L/lib/../lib64 -L/usr/lib/../lib64
> -lstdc++ -lm -lc -lgcc_s
> /usr/lib/gcc/x86_64-redhat-linux/3.4.2/crtendS.o
> /usr/lib/gcc/x86_64-redhat-linux/3.4.2
> /../../../../lib64/crtn.o  -Wl,-soname -Wl,libgnuradio-core.so.0 -o
> .libs/libgnuradio-core.so.0.0.0
> /usr/bin/ld: /usr/local/lib/libfftw3f.a(tensor.o): relocation R_X86_64_32
> against `a local symbol'
> can not be used when making a shared object; recompile with -fPIC
> /usr/local/lib/libfftw3f.a(tensor.o): could not read symbols: Bad value
> collect2: ld returned 1 exit status
> make[4]: *** [libgnuradio-core.la] Error 1
> ---
> The -fPIC suggestion seems odd; the option seems related to some older cpu
> architectures. Nevertheless, I tried to recompile libfftw3f and
> gnuradio-core with -fPIC, but received the same link error.
> Has anyone else done a gnuradio-core-2.4 64-bit compile on FC3? Or perhaps
> on FC2?
> Thanks,
> -Graham

I haven't tried a 64-bit on FC{2,3}.  From the command above it's
trying to link against a static library version of libfftw3f.  See if
you can't find or build a shared library version of FFTW 3.x
./configure --enable-shared  ought to do it.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]