[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Discuss-gnuradio] wxPython and FC3

From: mgray
Subject: [Discuss-gnuradio] wxPython and FC3
Date: Thu, 24 Mar 2005 22:24:48 -0700 (MST)

What is the best way to get wxPython working under Fedora Core 3?  

I tried to download and build the source, but it has been very painful.

When I run the program I typically get core dumps:

address@hidden usrp]$ ./usrp_fft.py
usrp: found usrp rev2
RX d'board A: Basic Rx
RX d'board B: Basic Rx
Segmentation fault (core dumped)
address@hidden usrp]$ 

address@hidden usrp]$ ./wfm_rcv_gui.py 10.7
usrp: found usrp rev2
RX d'board A: Basic Rx
RX d'board B: Basic Rx
usrp_standard_rx::set_decim_rate: WARNING rates > 128 result in incorrect 
>>> gr_fir_fff: using SSE
Segmentation fault (core dumped)

On a good note, the O'scope works alright usrp_oscope.py 

Thanks for any assitance...

The following was my last build attempt:

tar zxf wxPython-src- 
cd wxPython-src-
mkdir bld
cd bld
../configure --prefix=$HOME/gr \
--enable-rpath=$HOME/gr \
--with-gtk \
--with-opengl \
--enable-debug \
--enable-geometry \
--enable-sound --with-sdl \
--enable-display \
--disable-debugreport \
--with-libjpeg=builtin \
--with-libpng=builtin \
--with-libtiff=builtin \

make -C contrib/src/gizmos
make -C contrib/src/stc

make install
make install -C contrib/src/gizmos
make install -C contrib/src/stc

cd ../wxPython
python setup.py build
python setup.py install --prefix=$HOME/gr

I'm using the following support packages:

tar zxf fftw-3.0.1.tar.gz
tar xzf swig-1.3.24.tar.gz
tar xzf cppunit-1.10.2.tar.gz
tar xzf sdcc-2.4.0.tar.gz
tar zxf xerces-c-src_2_6_0.tar.gz

The of the GNU radio core compiles and runs without any problems.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]