[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Discuss-gnuradio] ReG - Building GNU Radio

From: Don Ward
Subject: Re: [Discuss-gnuradio] ReG - Building GNU Radio
Date: Tue, 10 Oct 2006 14:49:50 -0400

Hi Shriram,

I have downloaded and built the GNU radio source code release 3.0 (Minimal Build) on cygwin. The installation went without any error. But when i tryied to run the sample dial_tone.py, i didnt get any error but at the same time there was no dial tone sound at the output. So i checked that the "WAVE" source was enabled in the audio control panel as
instructed, but still no output came.

If GNU Radio and Python don't complain, then you are probably pretty close.

When you run dial_tone.py, does it come back with a prompt or does it hang until you type Ctrl-C?

Does your pc play sounds when you log on, log off, or click on a link? If not, the problem is with your pc sound (speakers, sound card, mixer settings, etc.).

You can check the Cygwin emulation of the OSS sound device with

   cat C:/Windows/Media/ringin.wav > /dev/dsp

(If you don't have ringin.wav, look for the file samples/sound/cuckoo.wav that came with wxPython and use it instead.) If this produces no sound, then the problem is with Cygwin's OSS emulation.

If the tests above produce sound, then either there is a problem in GNU Radio, or it is asking your sound hardware to do something it can't do. You might try using the "-r" option on dial_tone.py to specify a playback sampling rate, e.g.:

   python dial_tone.py -r 8000
   ./dial_tone.py -r 21400

Another thing you might try is using the Windows sound driver instead of OSS. One way to do this is to make a copy of dial_tone.py that uses the Windows sound driver. Do this by changing the line

   from gnuradio import audio
   from gnuradio import audio_windows as audio

in a copy of dial_tone.py.

Earlier when i was installing the wxpython module as stated in the page


all the steps went well, but when i tried to run the demo.py as indicated in the 13th step, I didnt get the output and no error was reported. I feel these two issues have a link and hence i tried the steps once again, but then got the same problem again.....No Output and No
error... Where could the problem be??

dial_tone.py doesn't use wxPython, so there probably isn't a direct connection, but there could be an indirect connection. Perhaps Python is not set up correctly. What output do the following commands produce?

   which python
   ls -l `which python`
   python -V
   cygcheck -c python
   cygcheck /usr/bin/python2.4

(I assume you are using Python version 2.4, that you are running dial_tone.py from a Cygwin shell window, and that PYTHONPATH is set to /usr/local/lib/python2.4/site-packages.)

Let me know if any of this helps or if you can supply any additional information.

-- Don W.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]