[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Discuss-gnuradio] help with USRP and USB permissions

From: George Nychis
Subject: Re: [Discuss-gnuradio] help with USRP and USB permissions
Date: Mon, 12 Feb 2007 19:21:55 -0500
User-agent: Thunderbird 2.0b1 (X11/20070206)

flawless victory

but now i have another problem, that i some how created using those two
methods below... I searched the mailing list and google for this but
couldn't find a solution.

address@hidden ~/school/SDR/gnuradio/gnuradio-examples/python/usrp $
write_internal_ram failed: error sending control message: Protocol error
usrp: failed to load firmware /usr/share/usrp/rev2/std.ihx.

In dmesg:
usb 1-7: usbfs: USBDEVFS_CONTROL failed cmd python rqt 64 rq 160 len 3
ret -71

I did not change any kernel settings... only things i changed are what i
listed as trying to get the permission thing to work.

We have two USRP's and two desktops, the board worked on the other
desktop, therefore its not the board ... and i tried the other board on
my desktop and it doesn't work... so its gotta be my comp.

Additionally, I tried make uninstall and rebuilt everything... no change

any ideas?


Eric Blossom wrote:
On Mon, Feb 12, 2007 at 11:59:07AM -0500, George Nychis wrote:
Hey all,

I've seen two different methods for setting up USB permissions correctly, and I can't seem to get either to work. The first way is udev, the other method is hotplug.

So I tried udev first, and created /etc/udev/rules.d/60-usrp.rules:
# USRP without loaded firmware (FX2)
BUS=="usb", SYSFS{idVendor}=="fffe", SYSFS{idProduct}=="0002", SYSFS{bcdDevice}=="0002", GROUP="usrp", RUN+="/usr/local/bin/usrper load_standard_bits" BUS=="usb", SYSFS{idVendor}=="fffe", SYSFS{idProduct}=="0002", SYSFS{bcdDevice}=="0004", GROUP="usrp", RUN+="/usr/local/bin/usrper load_standard_bits"

The suggestion in the wiki is known to work.

This is the relevant part from http://gnuradio.org/trac/wiki/UdevConfig:

# rule to grant read/write access on USRP to group named usrp.
# to use, install this file in /etc/udev/rules.d as 10-usrp.rules
ACTION=="add", BUS=="usb", SYSFS{idVendor}=="fffe", SYSFS{idProduct}=="0002", 
GROUP:="usrp", MODE:="0660"


reply via email to

[Prev in Thread] Current Thread [Next in Thread]