[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Discuss-gnuradio] Python blocks in a new package

From: Ed Criscuolo
Subject: [Discuss-gnuradio] Python blocks in a new package
Date: Tue, 20 Nov 2007 14:29:49 -0500
User-agent: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.7.13) Gecko/20060414

I've been creating a new package, called tdrss, based on the examples
in gr-howto-write-a-block-3.1.1.  The C++ blocks in src/lib and the
QA tests in src/python all work fine, but I've been having a problem
intalling the one Python block I wrote.

It's in a subdir called tdrss_utils that is under src/python.  I
added a line "SUBDIR = tdrss_utils" to the Makefile.am in src/python,
put a copy of __init__.py in src/python/tdrss_utils, and
created a Makefile.am in src/python/tdrs_utils containing:


include $(top_srcdir)/Makefile.common

# Install this stuff so that it ends up as the gnuradio.tdrss_utils
# module
# This usually ends up at:

tdrss_utilspythondir = $(grpythondir)/tdrss_utils
tdrss_utilslibdir    = $(grpyexecdir)/tdrss_utils

tdrss_utilspython_PYTHON =                      \
        __init__.py                     \



If I run bootstrap, no Makefile.in or Makefile get created,
and when I run make, I get:

Making all in python
Making all in tdrss_utils
make[4]: *** No rule to make target `all'.  Stop.

What automake magic am I missing?

@(^.^)@  Ed

reply via email to

[Prev in Thread] Current Thread [Next in Thread]