[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Re: [Discuss-gnuradio] USRP Audio Rate versus Sample Rate of Soundca

From: meggahertz
Subject: Re: Re: [Discuss-gnuradio] USRP Audio Rate versus Sample Rate of Soundcard
Date: Wed, 13 Feb 2008 19:49:15 -0500

Thanks a lot everyone! 

I am using an alsa_source however when using "plughw:0,4", or "plughw:0,0" 
instead of "hw:0,4" (which I am currently using) I get the following message:

 audio_alsa_source[plughw:0,0]: set_periods failed: Invalid argument
Traceback (most recent call last):
  File "./fm_transmit_temp_sc.py", line 134, in <module>
  File "./fm_transmit_temp_sc.py", line 107, in __init__
    src = audio.source(44100, options.audio_input)
  File "/usr/local/lib/python2.5/site-packages/gnuradio/audio_alsa.py", line 
219, in source
    return _audio_alsa.source(*args)
RuntimeError: audio_alsa_source

What could cause this? My alsa drivers seem to be updated.

Juha : "You could also try sampling the audio with USRP and LFRX. I've never
tried it, but I don't see why it wouldn't work." 

I have yet to try this. I plan on doing this if the other method doesn't work 
at all.

Juha : "Do you see any of the letters in the set {U,a,O,u} while running your 

I was seeing them before. however as I made the audio_rate closer to 44.1K they 
have disappeared so looks like I am ok there.

This message was sent on behalf of address@hidden at openSubscriber.com

reply via email to

[Prev in Thread] Current Thread [Next in Thread]