[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Discuss-gnuradio] Impedance Issue with the USRP/LFRX

From: Karthik Vijayraghavan
Subject: Re: [Discuss-gnuradio] Impedance Issue with the USRP/LFRX
Date: Thu, 20 Nov 2008 22:11:21 -0800

What is the output impedance of your preamplifier? I do similar data
acquisition with the LFRX and I pass my signals through an op-amp
buffer and through a 50ohm series resistor at the output so I get a
gain of 0.5. That has always worked for me.

You could test this out by hooking up a signal generator with a 50ohm
output impedance directly to the LFRX or through the opamp buffer and
sending in a known voltage.


On Thu, Nov 20, 2008 at 6:17 PM, dan s <address@hidden> wrote:
> Hi,
> I'm trying to figure out an impedance problem with my USRP/LFRX system.  I
> am using the LFRX daughtercard to measure background noise from a hydrophone
> (underwater microphone).  I am using a +40dB gain preamplifier to amplify
> the signal from the hydrophone and then I feed it into the LFRX channel A.
> I am pretty sure that even with a preamplifier, the 50ohm input impedance of
> the LFRX is too low.  I am using a dynamic signal analyzer (with 10Mohm
> input impedance) to measure the output of the preamplifier/hydrophone.  If I
> use a Tee SMA connector and then a coax line in to the LFRX, I notice a
> voltage drop factor of about 3.22 in my dynamic signal analyzer response.
> This test was performed by using a transducer in a bucket to generate a
> single frequency tone.
> I performed this test for an array of frequencies and the voltage drop
> factor varied from 3.22 (at 10khz) to 4.48 (at 100 kHz).
> Does anyone know how I could overcome this impedance mismatch?  When I test
> this out with the hydrophone and no preamplifier, the effect is even more
> drastic because the hydrophone cannot drive the 50 ohm input impedance of
> the LFRX.  I am confident the preamplifier is working properly.
> I tried removing the R9 50ohm resistor.  When I tried measuring a signal
> with that resistor gone, I measured absolutely no response (zeros in my data
> file using usrp_cfile_rx.py)
> Are there any other circuitry changes I can try in the lab?
> Thanks,
> Dan
> _______________________________________________
> Discuss-gnuradio mailing list
> address@hidden
> http://lists.gnu.org/mailman/listinfo/discuss-gnuradio

reply via email to

[Prev in Thread] Current Thread [Next in Thread]