[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Discuss-gnuradio] 'make check' fails on OS X 10.5 with gnuradio 3.1 rel

From: Jakub Moskal
Subject: [Discuss-gnuradio] 'make check' fails on OS X 10.5 with gnuradio 3.1 release
Date: Mon, 9 Feb 2009 23:55:45 -0500


After installing all necessary libraries using MacPorts and following
instructions from Jon Jacky
(http://staff.washington.edu/jon/gr-osx/gr-osx.html), the make check
fails on my MacBook Pro.. Ignoring that and issuing 'make install'
leads to the same error when trying to import gnuradio in python:

dyld: Library not loaded: /opt/local/lib/libfftw3f.3.dylib
 Referenced from:
 Reason: Incompatible library version: test_all requires version
6.0.0 or later, but libfftw3f.3.dylib provides version 5.0.0
/bin/sh: line 1: 26477 Trace/BPT trap          ${dir}$tst
FAIL: test_all

I installed the fftw-3-single using MacPorts, 'port installed'
includes the following lines:
 fftw-3 @3.2_1 (active)
 fftw-3-single @3.2_0 (active)

What does the 'version 6.0.0' or '5.0.0' refer to? As far as I know
there is no newer version of the fftw-3-single which provides the
library in question. Anyone else came across the same problem?

Any help greatly appreciated!

reply via email to

[Prev in Thread] Current Thread [Next in Thread]