[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

RE: [Discuss-gnuradio] USRP2 PPS and REF

From: Suprin, Charles E.
Subject: RE: [Discuss-gnuradio] USRP2 PPS and REF
Date: Fri, 13 Feb 2009 14:43:17 -0500


Working only on my single channel setup, what appears to happen is that there 
is the time stamp for the first sample in the frame. The frame alignment seems 
to remain a function of when the device was turned on.

Now if sync_every_pps worked with the 31 December 2008 firmware.  I think I 
need to wait for a newer FPGA/VHDL firmware release for that to happen.


-----Original Message-----
From: address@hidden [mailto:address@hidden On Behalf Of Douglas Geiger
Sent: Friday, February 13, 2009 2:02 PM
To: address@hidden
Subject: Re: [Discuss-gnuradio] USRP2 PPS and REF

 Ok - so I have packets coming in from both USRP2's now, getting dumped
to their separate files.
 My app prints out the timestamp of each frame that gets sent to the
copy handler: if my 1PPS source is working properly, should the
timestamps coming out of the two USRP2's be identical?
 Another question: no matter what, there is going to be some time delay
between when I tell one USRP2 to start, and when I tell the other one to
start: with the timestamps I could do something like
align_on_samplenumbers (but with the timestamps - at least I could do
this in the copy handler where I have access to this information). Of
course this requires that the timestamps do end up being based on the
1PPS. Should I take that as a sign my USRP2's are not currently getting
sync'd to the 1PPS?

Doug Geiger
Research Assistant
Communications and Signal Processing Lab
Oklahoma State University

Discuss-gnuradio mailing list

reply via email to

[Prev in Thread] Current Thread [Next in Thread]