[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Discuss-gnuradio] audio_alsa_sink problem

From: Arto Oksanen
Subject: Re: [Discuss-gnuradio] audio_alsa_sink problem
Date: Sun, 1 Mar 2009 23:29:19 +0200

Using plughw:0,0 does not change anything. The error is the same.


2009/3/1 Eric Blossom <address@hidden>:
> On Sun, Mar 01, 2009 at 09:38:31PM +0200, Arto Oksanen wrote:
>> When trying to use audio sink in GRC I get following error:
>> audio: using audio_alsa
>> audio_alsa_sink[hw:0,0]: set_period_time_near failed: Invalid argument
>> Traceback (most recent call last):
>>   File "/home/gr/top_block.py", line 45, in <module>
>>     tb = top_block()
>>   File "/home/gr/top_block.py", line 32, in __init__
>>     self.audio_sink_0 = audio.sink(44100, "", True)
>>   File "/usr/local/lib64/python2.5/site-packages/gnuradio/audio_alsa.py",
>> line 307, in sink
>>     return _audio_alsa.sink(*args, **kwargs)
>> RuntimeError: audio_alsa_sink
>> The audio test samples in gnuradio-examples/python/audio do work with
>> no problems.
>> I tried to google for further information, but found only the archive
>> of this mail list suggesting to search the net for the solution. Looks
>> like a recursive solution for me. :-)
> Thanks for searching first!
>> I am new to gnuradio stuff so it may well be my ignorance causing
>> this, but I can not find any tutorials or manuals or documentation
>> especially for the GRC.
> I've seen the error before (but not on my h/w).  Can you try using
> plughw:0,0 instead of hw:0,0 and see if that changes anything?
> Eric

Arto Oksanen
Muurame, Finland

reply via email to

[Prev in Thread] Current Thread [Next in Thread]