[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Discuss-gnuradio] xcvr2450, v3.2 and usrp1

From: William Sherman
Subject: [Discuss-gnuradio] xcvr2450, v3.2 and usrp1
Date: Tue, 16 Jun 2009 01:31:53 +0200

Hi I am using Gnuradio v3.2 and usrp1.

I was using modified examples\digital\transmit_path, receive_path to
send and receive packets on the RFX2400. This was working alright.

I wanted more transmit power (+ adjustable gain) so I exchanged the
RFX2400 boards for XCVR2450 boards. However when I run my packet
transmitter program (which worked fine with RFX2400) the XCVR2450 boards
did not transmit! The program was not reporting any errors, but looking
at on usrp_fft or on a spectrum analyser, no signal was being output.
Likewise with my receiver: running usrp_fft with the XCVR2450 it could
not pick up signals.

Do I need to add in extra things to my code to get it to work with
XCVR2450 boards? I set the gain on the subdevs to maximum. Do XCVR2450
boards work with usrp1 and gnuradio v3.2?

Another question: When I transmit a packet it should occupy only a
limited bandwidth from the RRC filter. However in actual fact, running
it causes quite a jump in the noise floor. I also noticed with siggen
that there were considerable sidebands/harmonics being produced. Is
there a way to reduce or eliminate effect of packet raised noise floor /

I am working at ~2.4/2.5GHz (since my antennae work at this frequency,
although I am currently swapping between antennae and SMA cables)
Posted via http://www.ruby-forum.com/.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]