[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Discuss-gnuradio] Error & Question about audio_alsa_sink

From: Milo Wong
Subject: [Discuss-gnuradio] Error & Question about audio_alsa_sink
Date: Wed, 22 Jul 2009 10:11:11 -0700

Hi all,

I have a question about one of the examples in GNUradio 3.2.2 under Ubuntu9.04. I tried to run usrp_nbfm_rcv.py to test the usrp board. However, I met the following errors:
Using RX d'board A: Flex 2400 Rx MIMO B
len(rx_chan_coeffs) = 397
>>> gr_fir_ccc: using SSE
len(audio_taps) = 423
>>> gr_fir_fff: using SSE
audio_alsa_sink[hw:0,0]: unable to support sampling rate 32000
  card requested 44100 instead.
audio_alsa_sink[hw:0,0]: set_period_time_near failed: Invalid argument

Traceback (most recent call last):

File "usrp_nbfm_rcv.py", line 382, in <module>
    app = stdgui2.stdapp (my_top_block, "USRP NBFM RX")
File "/usr/lib/python2.6/dist-packages/gnuradio/wxgui/stdgui2.py", line 36, in __init__

    wx.App.__init__ (self, redirect=False)


return _audio_alsa.sink(*args, **kwargs)
RuntimeError: audio_alsa_sink

I found that someone met the similar problems as I have. And the answer from Johnathan is that the sound card is in use by some other application, possibly a previous run of a GNU Radio application that didn't exit cleanly.
I tried to restart the system and re-run the program but the error is still there. So I guess the sound card may not be used by some other application, but something else such as configuration of sound card...?
BTW, I also run this program on another computer, and it can get through! But I still have no idea why I still have the error above in my first run. Can any one help me with this question? Thanks in advance!



reply via email to

[Prev in Thread] Current Thread [Next in Thread]