[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Discuss-gnuradio] Problem on gsr-aloha

From: Alaelddin Fuad Yousif Mohammed
Subject: [Discuss-gnuradio] Problem on gsr-aloha
Date: Sat, 10 Oct 2009 15:25:55 +0200

Hi All

I downloaded gsr-aloha from http://www.cs.uni-paderborn.de/en/research-group/research-group-computer-networks/projects/gsr.html

I installed all parts of the gsr aloha projects as defiend

1.)     The PHY and DLC functions are implemented as GNU Radio signal blocks.
    They are in the "./signalblocks" directory. Copy these files into
    "../gnuradio-core/src/lib/general/". Then you must modify the "general.i"
    and the "Makefile.am" in the mentioned directory. In "general.i" the *.h
    and *.i -files and in "Makefile.am" the *.cc, *.h and *.i -files of the
    new signal blocks must be added. After that recompile the GNU Radio sources
    by running "make" in "../gnuradio-core"-directory. To install the new
    signal blocks run "make install".

but when I run "make" I recieved the following error

gr_convolution_dec.cc:364: warning: ‘int flush(long unsigned int*, unsigned int, unsigned char*)’ defined but not used
make[4]: *** [gr_convolution_dec.lo] Error 1
make[4]: Leaving directory `/gnur:
make[3]: *** [all] Error 2
make[3]: Leaving directory `/gnuradio-3.2.2/gnuradio-core/src/lib/general'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/gnuradio-3.2.2/gnuradio-core/src/lib'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/gnuradio-3.2.2/gnuradio-core/src'
make: *** [all-recursive] Error 1

2.)     Install the Viterbi libraries as describe in ".viterbi/HowToInstallViterbi".

3.)     Copy the sender control scripts (Python/sender) to the sender computer and the receiver
    control scripts (Python/receiver) to the receiver computer.

I go ahead and did step 2 and 3. but when I run ./transceiver.py  I recieved the following error

# ./transceiver.py
Traceback (most recent call last):
  File "./transceiver.py", line 7, in <module>
    from gnuradio.blks import gmsk_demod
ImportError: No module named blks

any Help please

reply via email to

[Prev in Thread] Current Thread [Next in Thread]