[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Discuss-gnuradio] Printing from c++ code

From: David Knox
Subject: Re: [Discuss-gnuradio] Printing from c++ code
Date: Sun, 18 Oct 2009 17:37:20 -0700 (PDT)

My first guess is that you have gnuradio modules installed on more than 
one place in your system; older modules compiled without the printfs are 
being used, and the newer ones have second priority in the search path. 
Try a sudo make uninstall, and run your program, you should get errors.

That was indeed the case.  I guess, during my various botched attempts at
gnuradio installation, I had created multiple directories of gnuradio
modules and then lost track of which one was actually 'working'. Changes to
the C code, followed by a 'sudo make install' in the same directory, now
have the desired effect, so  thanks very much.

Actually, sudo make uninstall didn't quite do it for me.  I had to remove a
fair number of gnuradio-related modules by hand... I found that Synaptic
uninstallation, then installation (followed by 're-installation' of certain
modules) worked quite well as a process.  

For the record, I tripped over the following minor issues during my
re-installation of gnuradio and the UCLA code:
 . there seem to be some dependencies between gnuradio-omnithread and
gnuradio-utils (re-installing gnuradio-omnithread in Synaptic removed the
offending gnuradio-utils incompatibilty by removing gnuradio-utils).
 . the UCLA installation procedure defaults to a '/usr/local' root
directory, which doesn't fit with gnuradio.  I changed the UCLA configure
file setting of ac_default_prefix to equal '/usr'.  After re-running the new
configure file, this worked for me. Note that bootstrap clobbers the
configure file (and any changes that you've made to it ;-/) so you don't
need/want to re-run this.  
View this message in context: 
Sent from the GnuRadio mailing list archive at Nabble.com.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]