[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Discuss-gnuradio] USRP2 VRT support

From: Eric Blossom
Subject: Re: [Discuss-gnuradio] USRP2 VRT support
Date: Mon, 28 Dec 2009 15:28:37 -0800
User-agent: Mutt/1.5.20 (2009-08-17)

On Mon, Dec 28, 2009 at 05:21:36PM -0500, Josh Blum wrote:
> Tim Pearce wrote:
> >Josh,
> >
> >The USRP2 doesn't respond when loaded with the firmware at:
> >http://www.ettus.com/usrp2_vrt
> >
> >I've just run find_usrps -e eth1 with wireshark running and can only see the
> >outgoing packet:
> >
> >1    0.000000    Toshiba_b4:52:54    Broadcast    0xbeef    Ethernet II
> >
> >Given the transport type is the old (I think) 0xbeef I guess this is wrong,
> >I'm just about to recheckout the source code and compile again, but "vrt" is
> >a directory present in where I compiled gnuradio from - I've just double
> >checked by:
> >
> The vrt directory was there prior to this work. A good way to verify
> that you pulled in the right branch would be to check
> usrp2/firmware/include/usrp2_eth_packet.h and see that it has the
> following defines:
> #define U2_DATA_ETHERTYPE             0xBEEF  // used in our data frames
> #define U2_CTRL_ETHERTYPE             0xBEF0  // used in our control frames
> Thats where the firmware and host code gets the ethernet transport
> type from.
> -Josh


Did you post a copy of the FPGA image?  They'll need that for any of
this stuff to work ;-)


reply via email to

[Prev in Thread] Current Thread [Next in Thread]