[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Discuss-gnuradio] Unexplained out-of-sequence packets...

From: Eric Blossom
Subject: Re: [Discuss-gnuradio] Unexplained out-of-sequence packets...
Date: Mon, 10 May 2010 17:04:23 -0700
User-agent: Mutt/1.5.20 (2009-08-17)

On Tue, May 11, 2010 at 09:24:18AM +0930, Ian Holland wrote:
> Hi All
> I am coming across problems when using USRP2s with certain decimation
> factors, and these problems are somewhat counterintuitive.
> For instance, either using our own code while simply waiting for samples
> to cross a threshold (so very little computation), I find that I am
> getting SSS, indicating out-of-sequence packets.
> This was for a decimation factor of 20. However, when I tried a
> decimation factor of 10, which should have increased both the Ethernet
> and the computational requirements, I no longer observed out-of-sequence
> packets.
> I tried the same sort of thing with usrp2_fft.py, trying decimations of
> 10, 16, and 20. For decimations 16 and 20, I got out-of-sequence packets
> within about 10 - 20 seconds, but with decimation factor 10 I saw no
> out-of-sequence packets even after a few minutes.
> Can anybody suggest what might be going on here?
> Thanks
> Ian.

What GNU Radio version are you using?  git? tarball?
What kind of hardware are you running on?
How much RAM is in the machine?
What OS and distribution are you running?
What kernel version are you using?
What else is running on the machine?
What USRP firmware are you using?

What does

  $ sudo ethtool -a eth<N>



reply via email to

[Prev in Thread] Current Thread [Next in Thread]