[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Discuss-gnuradio] USRP/gnuradio Issues in OS X

From: Mark J. Blair
Subject: [Discuss-gnuradio] USRP/gnuradio Issues in OS X
Date: Sat, 14 Aug 2010 23:19:39 -0700

Hi! I'm new to gnuradio, and I just got my USRP several days ago. I'm trying to 
use it with my Mac running Snow Leopard, and I'm having some issues with some 
of the USRP utilities and examples. I've built the gnuradio software from the 
head revision in the git repository, with the pre-requisite libraries supplied 
by MacPorts.

My USRP hardware appears to be working correctly, since I can run many of the 
examples such as usrp_fft.py, usrp_wfm_rcv.py, usrp_nbfm_rcv.py and 
usrp_siggen.py, all with reasonable results. Some of the other examples and 
utilities aren't working for me though. In this message I'll just focus on two 
of them: usrper and usrp_benchmark_usb.py.

I've tried running the test routine (?), and it fails like this:

~% usrper load_standard_bits
Assertion failed: (ctx != NULL), function usrp_find_device, file 
usrp_prims_libusb1.cc, line 184.

I've also tried running the bandwidth benchmark, and it fails like this:

...examples/usrp% ./usrp_benchmark_usb.py 
Testing 2MB/sec... usrp: libusb_control_transfer failed: Unknown error
usrp: failed to get hash
usrp: libusb_control_transfer failed: Unknown error
write_internal_ram failed
usrp: failed to load firmware /usr/local/share/usrp/rev4/std.ihx.
Traceback (most recent call last):
  File "./usrp_benchmark_usb.py", line 106, in <module>
    main ()
  File "./usrp_benchmark_usb.py", line 96, in main
    ok = run_test (rate, verbose)
  File "./usrp_benchmark_usb.py", line 67, in run_test
    usrp_rx = usrp.source_s (0, rx_decim, 1, 0x32103210, 
  File "/usr/local/lib/python2.6/site-packages/gnuradio/usrp/usrp_swig.py", 
line 2067, in source_s
    return _usrp_swig.source_s(*args, **kwargs)
RuntimeError: can't open usrp

Some notes on my build environment:

I found that I need to use the native gcc instead of the one provided by 
MacPorts in order for gr-audio-osx to build (it can't find some of the core 
audio headers otherwise), and that I need to pass some flags into configure so 
that the required libraries and headers are found. Also, MacPorts installs 
"libtoolize" as "glibtoolize" to avoid a name collision with the native Mac 
"libtool" program, so I created a symbolic from /usr/local/bin/libtoolize to 
/opt/local/bin/glibtoolize in order to get the bootstrap script to run. I 
configured the gnuradio software this way:

./configure CC="/usr/bin/gcc" \
            CXX="/usr/bin/g++" \
            CPPFLAGS="-I/opt/local/include -I/opt/local/include/qwt 
-I/opt/local/include/qwtplot3d" \
            LDFLAGS="-L/opt/local/lib -F/opt/local/Library/Frameworks" \
            --with-fusb-tech=libusb1 \
            --enable-gr-qtgui \

The two --enable* flags probably aren't strictly necessary, but they are 
leftover from when I was finding the pre-requisites for those packages by trial 
and error. Everything seems to build OK, and I can use the USRP with some of 
the examples. I tried "make check", and it passes a whole bunch of tests and 
then chokes when a test that I haven't identified yet complains about failing 
to connect to a socket. There are other examples which presently don't work for 
me, such as hfx2.py and usrp_am_mw_rcv.py... I'll try debugging those some more 
myself before I ask about them here.

Have any of y'all seen these kinds of failures before?

Thanks in advance for any hints or suggestions.

Mark J. Blair, NF6X <address@hidden>
Web page: http://www.nf6x.net/
GnuPG public key available from my web page.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]