[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Discuss-gnuradio] segmentation fault (core dump) -- help needed

From: Thomas H Kim
Subject: Re: [Discuss-gnuradio] segmentation fault (core dump) -- help needed
Date: Mon, 8 Nov 2010 12:58:14 -0500

Thank you all for your help.

Since I am new in Linux and GNU software Radio, I wanted to start from known good configuration people use, so I wiped out FC14 and installed FC13. After the fresh installation, it started working (I was able to hear tones from my PC's speaker when I ran noise, dial_done examples under GNU radio folder).
The FC14 I installed was for 32 bit architecture, and FC13 I installed today was for 64bit architecture.
Initially I thought it could be one of the three reasons which caused the segmentation fault:
1) Using FC14
2) Using x86_64 instead of i386

3) Operator error on gnu radio istallation procedure (likely...since I am not really Linux guy)

I still don't know exactly why it happen, but after talking to several ppl I think #3 was most likely the reason. It's too late to go back to my old config(I wish I could), but I wonder if I setup PYTHONPATH correctly or not. I searched for the python site-packages file and setup the path to the file. I realized that there were multiple site-packages files in this installation. I will try to figure out if the other site-packages file in other than .../lib/python2.x/ cause this problem when I get some time.
If I did that step correctly, then I need to install FC14 i386 on my workstation and see if I can reproduce it.

Again, thank you for your help.



From:        Tom Rondeau <address@hidden>
To:        Steven Clark <address@hidden>
Cc:        address@hidden
Date:        11/08/2010 12:36 PM
Subject:        Re: [Discuss-gnuradio] segmentation fault (core dump) -- help needed
Sent by:        address@hidden

On Mon, Nov 8, 2010 at 12:13 PM, Steven Clark <address@hidden> wrote:
> On Mon, Nov 8, 2010 at 11:52 AM, Thomas H Kim <address@hidden> wrote:
>> Steven,
>> Thank you very much for your email.
>> I installed Fedora Core13  x86_64, instead of i386, which I installed on
>> last Friday and it works now. But, I don't understand because i386 should
>> work on 64bit machine (that was what I've thought so far... what do you
>> think?)
>> I guess the problem could be
>> 1) Using FC14 (I don't know think so, but it is possible?)
>> 2) Using x86_64 instead of i386
>> 3) Operator error on gnu radio installation procedure (likely...since I am
>> not really Linux guy)
>> Thank you for your help!
>> Thomas
> Hi Thomas-
> (Don't forget to send replies to the mailing list, so we all get the benefit
> of the troubleshooting process)
> Just so I understand the sequence of events: under FC14 i386, with gnuradio
> installed via yum, you got the segmentation faults. Then, you installed FC13
> x86_64 on the same machine, without changing the gnuradio installation, and
> the segfaults were gone? Or did you also reinstall gnuradio?
> Either way, glad it is working now!
> -Steven

Thanks. If there is any way you know of to reproduce the problem, I'd
be very interested in hearing it. If there is a problem with Fedora
14, then I'd like to know where and hopefully fix it.

It shouldn't be a problem with 32 vs. 64-bit and I know people run GNU
Radio on Opterons and on Fedora 13. So it sounds right now like Fedora
14 is the variable. Anyone else used Fedora 14 yet?


Discuss-gnuradio mailing list

reply via email to

[Prev in Thread] Current Thread [Next in Thread]