[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Discuss-gnuradio] Cannot build USRP. ./configure reports sdcc is mi

From: Arya Santini
Subject: Re: [Discuss-gnuradio] Cannot build USRP. ./configure reports sdcc is missing in spite of it being installed!
Date: Wed, 10 Nov 2010 19:33:48 -0800


I tried these and it fixed the problem.

ln -s /usr/bin/sdcc-asx8051 /usr/bin/asx8051
ln -s /usr/bin/sdcc-aslink /usr/bin/aslink

Earlier I had tried exporting /usr/libexec/sdcc to PATH, but that didn't fix it.


On Wed, Nov 10, 2010 at 7:24 PM, Eric Blossom <address@hidden> wrote:
> On Wed, Nov 10, 2010 at 07:13:17PM -0800, Arya Santini wrote:
>> Hi List,
>> I'm trying to build GNU Radio from source, and when I run ./configure,
>> I see USRP is not going to be built under the heading : "The following
>> components were skipped either because you asked not to build them or
>> they didn't pass configuration checks:"
>> gcell
>> usrp
>> gr-usrp
>> gr-gcell
>> gr-audio-jack
>> gr-audio-osx
>> gr-audio-portaudio
>> gr-audio-windows
>> gr-comedi
>> gr-gpio
>> gr-radar-mono
>> gr-video-sdl
>> gr-sounder
>> gr-utils
>> This is the text from ./configure pertaining to USRP:
>> checking for sdcc... sdcc -mmcs51 --no-xinit-opt
>> checking for asx8051... no
>> USRP requires sdcc. sdcc not found. See http://sdcc.sf.net
>> Unable to find firmware compiler SDCC.
>> Not building component usrp.
>> Why? I've installed sdcc and double checked it. Still I cannot get
>> USRP to build. I'm on Fedora 12. Please help.
>> Thanks,
>> Arya.
> Fedora installs it into /usr/libexec/sdcc.
> Add /usr/libexec/sdcc to your path:
>  $ PATH=$PATH:/usr/libexec/sdcc.
> Eric

reply via email to

[Prev in Thread] Current Thread [Next in Thread]