[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Discuss-gnuradio] UHD IP Address Setting Issue

From: Marcus D. Leech
Subject: Re: [Discuss-gnuradio] UHD IP Address Setting Issue
Date: Tue, 16 Nov 2010 12:20:06 -0500
User-agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv: Gecko/20101103 Fedora/1.0-0.33.b2pre.fc14 Thunderbird/3.1.6

On 11/16/2010 11:57 AM, Gregory, Adam wrote:

Hi all,


I’m trying to get a MIMO setup working using USRP2s with the UHD drivers. I have a PC with 2 gigabit Ethernet interfaces, and a USRP2 connected to each.


My problem is that I can’t change the USRP2 IP address so that the two devices have different addresses. I can set the IP address in the motherboard EEPROM using usrp_burn_mb_eeprom, and I can see the updated IP address reported when I run uhd_usrp_probe, but the IP address the USRP2 answers to is still


Power-cycling the device has no effect, nor does trying another PC in case of any address caching. I’ve tried with UHD firmware & fpga images built myself from the latest git, and also with the 01/09/2010 release.


I’ve seen on the mailing list archives that some people have had success with MIMO and UHD, and I haven’t found any reference to IP address problems. I must be missing something. Could anyone help please?


Thanks in advance,



Send us an "ifconfig" of your two GiGe interfaces

reply via email to

[Prev in Thread] Current Thread [Next in Thread]