[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Discuss-gnuradio] message queue problem in bbn_80211b_tx.py

From: Rachel Li
Subject: [Discuss-gnuradio] message queue problem in bbn_80211b_tx.py
Date: Sun, 6 Feb 2011 14:37:53 -0800 (PST)

Hi, all,

I am trying to communicate between two USRP1 with the bbn_80211b_tx.py and bbn_80211b_rx.py. My OS is Ubuntu 10.10, but I have no idea what is my GNU Radio release(if anyone can help me to find out it, it will be very appreciated.)

First, I tried to transmit the getty.txt. I run the command line as following:


and got the output as following:

Using TX d'board A: Flex 2400 Tx MIMO B
>>> gr_fir_ccf: using SSE
spb:       8
interp:   32
Sending pkt  0
Sending pkt  1
Sending pkt  2

then it was just stuck there, no response at all, even I make ctrl+c. I had to kill the process to terminated it.

By reading the code, I guessed the problem is related with the message queue, and I modified the message limit from 2 to 5, then it was stuck on 'Sending pkt 5'.

So, I guessed the problem is, the packets in the message queue were not sent out at all, so when the message queue reached its limit, it just stopped. I have tried to look around for any possible resolution but didn't get any.

Has anyone encountered the same problem before? Any suggestions will be very helpful!

Thank you in advance!


reply via email to

[Prev in Thread] Current Thread [Next in Thread]