[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Discuss-gnuradio] Cannot detect USRP N210

From: François Darracq
Subject: Re: [Discuss-gnuradio] Cannot detect USRP N210
Date: Thu, 10 Feb 2011 15:43:38 +1100


First, thank you for yours answers. I did not see that point and so I re-install gnuradio and uhd as showed in the link you gave me using the git. Everything went good but when I run uhd_find_devices, I have this message :

address@hidden:~$ uhd_find_devices
#linux; GNU C++ version 4.4.5; Boost_104200; UHD_002.20110206225409.aea6ac1

#    Ignoring discovered device
#    Expected protocol compatibility number 8, but got 7:
#    The firmware build is not compatible with the host code build.
#No UHD Devices Found

Do I have to update directly the firmware installed on the USRP ? or it is just a problem on the computer ? Thank you again.


2011/2/9 Marcus D. Leech <address@hidden>
On 02/08/2011 10:28 PM, Anoth wrote:
> Hi everybody,
> I am using gnuradio 3.2.2. on Ubuntu 10.10 with an USRP N210. I have
> installed GNURadio thanks to the binary package installation and GNU Radio
> Companion. Everything went good as I can open grc. I have also configured my
> ethernet card (intel pro/1000GT desktop adapter) on the eth1 interface to
> communicate with the USRP. I can ping the USRP (ping which
> means that the computer can communicate with the USRP. But, when I run
> find_usrps or usrp2_fft.py on the terminal, I have these messages :
> address@hidden:~$ find_usrps
> No USRP2 found.
> or
> address@hidden:~$ usrp2_fft.py -e eth1
> Traceback (most recent call last):
>   File "/usr/bin/usrp2_fft.py", line 273, in <module>
>     main ()
>   File "/usr/bin/usrp2_fft.py", line 269, in main
>     app = stdgui2.stdapp(app_top_block, "USRP2 FFT", nstatus=1)
>   File "/usr/lib/python2.6/dist-packages/gnuradio/wxgui/stdgui2.py", line
> 36, in __init__
>     wx.App.__init__ (self, redirect=False)
>   File "/usr/lib/python2.6/dist-packages/wx-2.8-gtk2-unicode/wx/_core.py",
> line 7978, in __init__
>     self._BootstrapApp()
>   File "/usr/lib/python2.6/dist-packages/wx-2.8-gtk2-unicode/wx/_core.py",
> line 7552, in _BootstrapApp
>     return _core_.PyApp__BootstrapApp(*args, **kwargs)
>   File "/usr/lib/python2.6/dist-packages/gnuradio/wxgui/stdgui2.py", line
> 39, in OnInit
>     frame = stdframe (self.top_block_maker, self.title, self._nstatus)
>   File "/usr/lib/python2.6/dist-packages/gnuradio/wxgui/stdgui2.py", line
> 60, in __init__
>     self.panel = stdpanel (self, self, top_block_maker)
>   File "/usr/lib/python2.6/dist-packages/gnuradio/wxgui/stdgui2.py", line
> 81, in __init__
>     self.top_block = top_block_maker (frame, self, vbox, sys.argv)
>   File "/usr/bin/usrp2_fft.py", line 70, in __init__
>     self.u = usrp2.source_32fc(options.interface, options.mac_addr)
>   File "/usr/lib/python2.6/dist-packages/gnuradio/usrp2.py", line 679, in
> source_32fc
>     return _usrp2.source_32fc(ifc, mac)
> RuntimeError: No USRPs found on interface eth1
> I have tried to install GNURadio by the other ways but the problem remains.
> I have searched a lot on forums and I have tried a lot of things without
> succeeding to detect the USRP. Do you have any solutions ? Thank you very
> much
> Francois
The N210 is a UHD-only device.  You'll need a more recent version of Gnu
Radio, and you'll
 need to follow the UHD build instructions here:


Also, find_usrps, and usrp2_fft.py are "classic" API programs--they
won't work with UHD devices.

But you can synthesize the functionality of usrp2_fft.py for UHD within
GRC pretty easily.

You can use uhd_find_devices (once you have UHD, and Gnu Radio
compatible with UHD) to find
 UHD-type devices.

Principal Investigator
Shirleys Bay Radio Astronomy Consortium

Discuss-gnuradio mailing list

L'univers est grand, ne vous y perdez pas !

reply via email to

[Prev in Thread] Current Thread [Next in Thread]