[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Discuss-gnuradio] Piping to the USRP - mkfifo issue

From: Tom Rondeau
Subject: Re: [Discuss-gnuradio] Piping to the USRP - mkfifo issue
Date: Sun, 6 Mar 2011 19:53:56 -0500

On Sun, Mar 6, 2011 at 6:59 PM, Tom Hendrick <address@hidden> wrote:

  I am using a web camera to get an MPEG-4 rtsp stream that is set to a constant bitrate.  I have a script which pipes the rtsp stream to a code in C++.  The C++ code modulates the signal and writes  a .WAV file to the hard disk.

I have a python script which interfaces with GNURadio/USRP which I created using GRC.  This takes a file stored on the hard disk and outputs the analog waveform on the output of the USRP and I run this in a second terminal window.

Everything works on the transmitter side, except that I have a file that is constantly increasing in size, and the USRP script starts from the beginning of the file and plays for a certain time before stopping.  If I restart, it does it longer and longer each time as expected since the file is increasing in size.  I verified I have gotten an output on the USRP using an oscilloscope and it looked fine.

I wanted to try and use piping with mkfifo.

When I erase the file that is written/read from with the couple of scripts I have, I then use mkfifo temp.wav (where temp.wav is my .wav file). 

Then I start my scripts that pipe the camera output to the temp.wav file.  In a second terminal window I then run my USRP script and it seems to open the file but I don't get any output on the USRP.

Has anyone encountered this problem?  I'm not sure what could be wrong, but it works with a normal file as I described above. Any suggestions?

Thanks for your help!

Look how piping to fifo files is handled in the gr-atsc. That might help get you going.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]