[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Discuss-gnuradio] E100 - dial_tone.py error

From: Divya Paul
Subject: Re: [Discuss-gnuradio] E100 - dial_tone.py error
Date: Wed, 9 Mar 2011 09:51:58 -0800 (PST)

That worked! Thank you!

From: Philip Balister <address@hidden>
To: Divya Paul <address@hidden>
Cc: address@hidden
Sent: Tuesday, March 8, 2011 21:00:02
Subject: Re: [Discuss-gnuradio] E100 - dial_tone.py error

On 03/08/2011 11:12 AM, Divya Paul wrote:
> Hi,
> I am new to using GNUradio and the USRP hardware. I installed GNUradio, GRC and UHD on the E100. I have run the examples for the UHD and it is working without any problem. From the GNUradio examples, When I tried running the dial_tone.py, I get the following error:
> audio_alsa_sink[hw:0,0]: Device or resource busyTraceback (most recent call last):  File "./dial_tone.py", line 55, in<module>    my_top_block().run()  File "./dial_tone.py", line 48, in __init__    dst = audio.sink (sample_rate, options.audio_output)  File "/usr/local/lib/python2.6/site-packages/gnuradio/audio_alsa.py", line 329, in sink    return _audio_alsa.sink(*args, **kwargs)RuntimeError: audio_alsa_sink
> Also,in python, the importing of modules is working:Python 2.6.5 (r265:79063, Dec 14 2010, 12:41:31) [GCC 4.5.2 20101204 (prerelease)] on linux2Type "help", "copyright", "credits" or "license" for more information.>>>  from gnuradio import gr>>>  from gnuradio import audio>>>
> When I go to System-->  Preferences -->  Sound, a window pops up that says 'Waiting for sound system to respond'. Does this mean that there is no sound system? How can I verify that my GNUradio install on the E100 is done right?

The pulseaudio daemon may have grabbed the sound driver. Try "killall -9 pulseaudio" and try the test again.

I need to figure out why it works for some people and not others.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]