[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Discuss-gnuradio] USRP2 Ethernet link Issues

From: Praveen Vikram
Subject: [Discuss-gnuradio] USRP2 Ethernet link Issues
Date: Wed, 30 Mar 2011 21:38:13 -0400

Hi Everyone,

I am currently trying to play around with the USRP2, but am not even able to connect to it.

I have the latest UHD and GNURadio installed from git running on Ubuntu 10.04.
I'am connecting the USRP directly to the Gigabit Interface on my computer. 

I used the Firmware/FPGA image from http://www.ettus.com/downloads/uhd_images/UHD-images-most-recent/

When I switch on the USRP2, all the LED's light up and then LED D & F stay on. But,
-> None of the lights on the ethernet port light up.

-> uhd_find_devices says:
linux; GNU C++ version 4.4.3; Boost_104000; UHD_003.20110315195256.3a1ad3f

No UHD Devices Found

-> find_usrps says
No USRP2 found.

-> ethtool eth0 says
Settings for eth0:
Supported ports: [ TP ]
Supported link modes:   10baseT/Half 10baseT/Full 
                       100baseT/Half 100baseT/Full 
Supports auto-negotiation: Yes
Advertised link modes:  10baseT/Half 10baseT/Full 
                       100baseT/Half 100baseT/Full 
Advertised pause frame use: No
Advertised auto-negotiation: Yes
Link partner advertised link modes:  Not reported
Link partner advertised pause frame use: No
Link partner advertised auto-negotiation: No
Speed: Unknown!
Duplex: Unknown! (255)
Port: Twisted Pair
Transceiver: internal
Auto-negotiation: on
MDI-X: Unknown
Supports Wake-on: g
Wake-on: d
Link detected: no

-> lspci | grep Ethernet says
03:00.0 Ethernet controller: Broadcom Corporation NetXtreme II BCM5708 Gigabit Ethernet (rev 12)
0a:00.0 Ethernet controller: Broadcom Corporation NetXtreme BCM5721 Gigabit Ethernet PCI Express (rev 21)

I have two gigabit interfaces, i have tried to connect on both with the same result.

-> When I use wireshark to see if any packets are actually sent, I dont see anything going between the USRP2 and my computer.

I have set a static ip ( too.
I have tried different ethernet cables, made sure no pins are broken in either of the ethernet ports.

I'am not sure what I'am doing wrong. I have ferreted the mailing-lists for similar problems but couldn't find any solution. Any help will be appreciated at this point.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]