[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Discuss-gnuradio] Installation problem

From: Marcus D. Leech
Subject: Re: [Discuss-gnuradio] Installation problem
Date: Sat, 03 Sep 2011 14:22:53 -0400
User-agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv: Gecko/20110817 Fedora/3.1.12-1.fc14 Thunderbird/3.1.12

On 09/03/2011 01:16 PM, Greg Le Sage wrote:
I have a particular error that I have been unable to find described. I
would appreciate advice. I have searched very extensively and put in
many hours.

I performed a new install of Ubuntu 11.04 on a PC (Dell Precision
M6300), downloaded and performed sudo bash build-gnuradio.sh, after modifying it to look in a different
directory for FPGA code (the site was just changed and I appended /old to the web site address), and ran the script.
This all worked on two other PCs, and they will both open and run GRC
and talk to my USRP2. I want to use this new computer because it is
significantly faster.

There is *zero* reason to run build-gnuradio as root.  Zero.  It acquires root as it needs it.  Ordinary operations don't require root.
  Compiling C code, moving your own files around, editing those files.  You only need to be root to install stuff in the system directories, update
  system software, etc.  The build-gnuradio acquires that via "sudo" as it needs to.  Don't run it as root.  That's just a bad idea.

The script performs all of the preliminaries without error. It reaches
the following point.

Doing ldconfig...
Building Gnu Radio...
make failed

I viewed the log file which contained the following at the end.

/usr/bin/ld: cannot find -l/usr/lib/libboost_date_time-mt.so
/usr/bin/ld: cannot find -l/usr/lib/libboost_filesystem-mt.so
/usr/bin/ld: cannot find -l/usr/lib/libboost_program_options-mt.so
/usr/bin/ld: cannot find -l/usr/lib/libboost_regex-mt.so
/usr/bin/ld: cannot find -l/usr/lib/libboost_system-mt.so
/usr/bin/ld: cannot find -l/usr/lib/libboost_thread-mt.so
/usr/bin/ld: cannot find -loptimized
/usr/bin/ld: cannot find -ldebug
/usr/bin/ld: cannot find -l/usr/lib/libboost_unit_test_framework-mt.so
collect2: ld returned 1 exit status
make[5]: *** [libgnuradio-uhd.la] Error 1
make[5]: Leaving directory
make[4]: *** [all] Error 2
make[4]: Leaving directory
make[3]: *** [all-recursive] Error 1
make[3]: Leaving directory `/home/lesagegp/Downloads/gnuradio/gr-uhd'
make[2]: *** [all] Error 2
make[2]: Leaving directory `/home/lesagegp/Downloads/gnuradio/gr-uhd'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/home/lesagegp/Downloads/gnuradio'
make: *** [all] Error 2
Exiting Gnu Radio build/install

At least some of these files do exist
e.g. /usr/lib/libboost_date_time-mt.so

Next I tried downloading with git clone

And went through the steps
sudo ./bootstrap
sudo ./configure
sudo make

make fails again with the same errors

That's when I completely reinstalled Ubuntu to make sure no left over
files were causing a problem. Running the script on a fresh install
fails at exactly the same point.

This is my first question submission. I tried to make sure it is neither
obvious or already answered. I appreciate any advice.

I just downloaded the latest Gnu Radio via GIT, and did:

  make distclean; make clean
  make; sudo make install

It went entirely fine.  So, my assumption is that the very latest codebase relies on some pre-req that is satisfied on my system (Fedora 14), and
  not on Ubuntu.  What exactly, that is, I'm not sure.

Marcus Leech
Principal Investigator
Shirleys Bay Radio Astronomy Consortium

reply via email to

[Prev in Thread] Current Thread [Next in Thread]