[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Discuss-gnuradio] problem(s) while connecting USRP2 with GNURadio

From: Marcus D. Leech
Subject: Re: [Discuss-gnuradio] problem(s) while connecting USRP2 with GNURadio
Date: Sun, 04 Sep 2011 10:53:41 -0400
User-agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv: Gecko/20101027 Fedora/3.0.10-1.fc12 Thunderbird/3.0.10

On 04/09/11 10:32 AM, sumitstop wrote:
> I read almost everything on the forum regarding this problem and tried my
> best.I am providing as much details as possible hence the post became long.I
> hope it will help the forum to help.
> I am working with USRP2.I installed GnuRadio as well as UHD(Using Marcus D.
> Leech script).I changed the host computer IPV4 address to with
> subnet mask the firewall also.
> Now…
> 1.When I run usrp2_probe.py its returning the device Mac address :
> 00:50:c2:85:42
>  Name(ID):
> -1
> Converter Rate,gain Range,Freq Range.
> 2.When I run uhd_find_devices.py
> It returns linux; GNU C++ version 4.4.3; Boost_104000;
> UHD_003.001.002-a3e1cb7
> No UHD Devices found.
> 3.When I do ping
> Its says “destination host unreachable”
> 4.I also then tried to change the default IPV4 address of USRP2 by 
> sudo ./usrp2_recovery.py - -ifc=eth0 - -new-ip=
> Then I pinged but same “destination host unreachable”
> 5. Then I monitored the network traffic on wireshark.I found…..
> a.When I do usrp2_probe.py then there happens communication between host and
> USRP2 and the USRP2 sends back his mac address to the host(was clearily
> visible in the wireshark).
> b. But when I do uhd_find_devices.py then the host broadcasts message but
> there is no reply packet from usrp2 at all.
> 6.Then I scanned the network using nmap but was not able to find any device
> there with IPV4 address one) up.Then I also searched
> for but no help at all.
> 7. When I boot he USRP2 then all LED’s blinks as given in the youtube video
> i.e. all blink in the beginning and finally only D and F remains
> glowing.Also the green light to the left of the Ethernet cable keeps
> glowing.The orange light to the right keeps blinking now and then when I do 
> nmap scanning.
> 8.My host computers have gigabit Ethernet ports so that is not an issue I
> think.
> 9.I burnt my SD card with the firmware FPGA image as given at
> http://code.ettus.com/redmine/ettus/projects/public/wiki/U2binaries
> Raw Ethernet rel-20100603  d488c6b2  June 3, 2010 
> 5b73d3a67d7998d83936906dac0cb200
> Raw Ethernet, with XCVR2450  v3.3.1git Jun 08, 2010  Use this with Raw
> Ethernet and the XCVR2450
> I also checked the MD5 sum to make sure that I got the proper bin files.
> I have 3 USRP2 devices and the same problem prevails in all the three. 
> No communication is happening above the layer three.
> Let me know what more I should try.
> -----
> Sumit Kr.
> Research Assistant
> Communication Research center
> IIIT Hyderabad
> India
There are two different APIs for the USRP2 family--the original
"classic" API, which uses raw ethernet
  frames, and the newer UHD API, which uses a UDP/IP based
communications protocol.  Only the
  UHD API supports IP, and will thus respond to pings, and
uhd_usrp_probe requires that the device be
  running the UHD firmware.

If you ran the build-gnuradio script, the UHD firmware for the USRP2
will be in:


The two "worlds" (non-UHD and UHD) aren't mutually compatible. 
Applications that were written for
  the "classic" API for USRP2 will not work unmodified for the UHD API,
and the device has to have its
  firmware upgraded to run the UHD-based firmware, as shown above.

Principal Investigator
Shirleys Bay Radio Astronomy Consortium

reply via email to

[Prev in Thread] Current Thread [Next in Thread]