[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Discuss-gnuradio] sorry to re_post: audio_alsa_sink[hw:0]: Device o

From: Tom Rondeau
Subject: Re: [Discuss-gnuradio] sorry to re_post: audio_alsa_sink[hw:0]: Device or resource busy
Date: Tue, 20 Sep 2011 22:43:35 -0400

On Fri, Sep 16, 2011 at 1:16 AM, Qin Jian <address@hidden> wrote:
Sorry to post again.
As it was my first time to post on mail list, I didn't know how to reply messages in mail list, so I have to start a new thread and using this stupid way.

When I want to connect the signal to the sound card, an error occurs as below:
audio_alsa_sink[hw:0]: Device or resource busy
RuntimeError: audio_alsa_sink
I want the signal to be output to the sound card, but the card is in use.
I tried lsof|grep /snd and kill -TERM the process in using sound card pulseaudio, but doesn't work.
Then I uninstalled the pulseaudio but the problem remains.

I also tried to set the sound sink device name to be: hw:0 / pulse / plughw:0,0
none works.

Any suggestion?
And in last thread, Alex asked about:"access the ALSA interface with any other audio application".
I could run alsamixer and I could listen mp3 using Totem Movie Player on Ubuntu.

So, what next?

Qin Jian

Qin Jian,
This is an ALSA issue. You should try turning off any other application that might be trying to access the system's sound hardware, like your web browser.

This is such a lame answer, but one easy thing to try is to reboot your machine and try to run the GNU Radio app first thing and see if it works then.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]