[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Discuss-gnuradio] GSoC: Filter Design tool update

From: Mac A. Cody
Subject: Re: [Discuss-gnuradio] GSoC: Filter Design tool update
Date: Thu, 09 Aug 2012 22:59:52 -0500
User-agent: Mozilla/5.0 (X11; Linux x86_64; rv:14.0) Gecko/20120714 Thunderbird/14.0


Removing that code appears to have fixed the startup problem.  When I
execute gr_filter_design, the following message is displayed on the
console prior to the display of the gr_filter_design GUI:

QInotifyFileSystemWatcherEngine::addPaths: inotify_add_watch failed: No such file or directory
QFileSystemWatcher: failed to add paths: /home/mcody/.config/ibus/bus
Bus::open: Can not get ibus-daemon's address.
IBusInputContext::createInputContext: no connection to ibus-daemon

I'm not sure what this is for or if it is critical to proper operation of

I am trying to emulate an 8th-order Butterworth low-pass filter using
gr.iir_filter_ffd in GNU Radio.  I cannot seem to implement an IIR filter
with such a steep roll-off in
gr_filter_design.  The filter characteristic
I want are as follows:

Sample Rate: 128,000 sps
Cut-off (3 dB) frequency: 1200 Hz (0.009375 normalized)
End of Passband: 900 Hz (0.00703125 normalized)
Start of Stop Band: 6000 Hz (0.046875 normalized)
Max Loss in Pass Band: 1 dB
Min Attenuation in Stop Band: 110 dB

When I plug in the last four values above into
gr_filter_design and press
the Design button, the following message is displayed on the console:

BadCoefficients: Badly conditionned filter coefficients (numerator):
the results may be meaningless
  "results may be meaningless", BadCoefficients)

If I adjust the parameters to more conservative values, I can keep the
error message from displaying.  Unfortunately the designed Butterworth
filter does not meet my specifications.

In the end, I was hoping that the new functionality in
would help with solving another problem that I am having.  That is that
I cannot seem to get
gr.iir_filter_ffd to execute properly.  I tried
plugging in different sets of feed-forward (b) and feedback (a)
coefficients generated with
other IIR filter design tools (and now
gr_filter_design) without success.  I always end up with strange NaN
errors when I run GNU Radio scripts that include
gr.iir_filter_ffd.  I
have searched without success in finding useful guidelines for using



On 08/09/2012 12:18 AM, sreeraj r wrote:
The error that you were getting was from some dead code (I tried to add one arrowtop to the configurable band-diagrams and later left that feeling that it looks bad, but forgot to remove the code).

I have updated the repo now. Please clone my latest code and let me know if you are still facing that issue.


From: sreeraj r <address@hidden>
To: Mac A. Cody <address@hidden>; "address@hidden" <address@hidden>
Sent: Thursday, 9 August 2012 10:27 AM
Subject: Re: [Discuss-gnuradio] GSoC: Filter Design tool update

Hi Mac,

Could you please specify your version of pyqt. I have tested the tool with version 4.9.1. The error has nothing to do with gnuradio version.
Sreeraj Rajendran

From: Mac A. Cody <address@hidden>
To: address@hidden
Sent: Thursday, 9 August 2012 9:56 AM
Subject: Re: [Discuss-gnuradio] GSoC: Filter Design tool update


I downloaded your updates to the filter design tool from

https://github.com/zeroXzero/gr-filtdes (zeroXzero-gr-filtdes-6cd8f37.zip)

After unzipping the archive, I followed the build instructions, using

the cmake command, as follows:

/home/mcody/.../zeroXzero-gr-filtdes-6cd8f37 /usr/local

The build and install appeared to proceed well, but when I execute

gr_filter_design at the command prompt, I get the following error message:

Traceback (most recent call last):

  File "/usr/local/bin/gr_filter_design", line 55, in <module>
    from filtdes.banditems import *
  File "/usr/local/lib/python2.6/dist-packages/filtdes/banditems.py", line 193, in <module>
  File "/usr/local/lib/python2.6/dist-packages/filtdes/banditems.py", line 79, in __init__
    self.poly << QtCore.QPointF(3,5)
TypeError: unsupported operand type(s) for <<: 'QPolygonF' and 'QPointF'

Prior to running gr_filter_design, I had to set LD_LIBRARY_PATH

to /usr/local/lib.

I don't know what I am doing wrong. Should your distribution be placed in

a specific location?  I am using GNU Radio 3.6.1git-47-g884c23ef if that
is of any help. I am running Kubuntu 10.04.


Mac / AE5PH

Discuss-gnuradio mailing list

Discuss-gnuradio mailing list

reply via email to

[Prev in Thread] Current Thread [Next in Thread]