[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Discuss-gnuradio] GNU Radio (etc) via MacPorts Update

From: Michael Dickens
Subject: Re: [Discuss-gnuradio] GNU Radio (etc) via MacPorts Update
Date: Tue, 9 Jul 2013 08:11:24 -0400

Hi Peter - When I hear of the error "No module named gnuradio", I immediately 
wonder if the GNU Radio related ports were installed using the +swig variant.  
I prefer to use +full myself, to get everything that GNU Radio can do.  If you 
want just Python and GRC, there are variants for those.  If you did not install 
using one of these variants, just reinstall with the new variants -- MacPorts 
will handle the rest (deactivating the current install and so forth).  You can 
tell what is installed via "port installed".  If this does not solve the 
problem, email me off-list and I'll work with you to get it all working. - MLD

On Jul 9, 2013, at 1:17 AM, Peter <address@hidden> wrote:

> Thanks for maintaining this for the mac. I am just getting my feet wet in
> SDR. I have a working dongle that I can use with the gqrx.app program-- I
> can tune radio stations and hear them. I would like to start using gnuradio
> for its added flexibility and power. I tried installing gnuradio (3.7) and
> gr-osmosdr (compatible with the 3.7 API I think) using macports. Both seem
> to install just fine. Problem is that I can't seem to do anything. When I
> try the examples in /opt/local/share/gnuradio/examples/filter, I get the
> error that "No module named gnuradio" so the python module is not installed.
> I have tried searching in the macports python modules (the one currently
> selected, version 2.7) as well as the Apple native install and there is no
> gnuradio module. I have searched the /opt/local/bin directory for files
> that might be related but the only thing I can find is a file called
> gnuradio-config-info which doesn't do a whole lot (other than spit out
> config information.
> I can't do anything described in the gnuradio getting started page such as 
> uhd_fft or python uhd_fft.py (where is this python script supposed to be
> located by the way?)

reply via email to

[Prev in Thread] Current Thread [Next in Thread]