[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Discuss-gnuradio] Bitbaking GnuRadio with meta-sdr master issues

From: Murray Thomson
Subject: Re: [Discuss-gnuradio] Bitbaking GnuRadio with meta-sdr master issues
Date: Tue, 21 Apr 2015 14:43:08 +0100

On 20 April 2015 at 15:13, Philip Balister <address@hidden> wrote:

On 04/19/2015 11:07 AM, Murray Thomson wrote:
> Hello,
> I have built the gnuradio-dev-image for an arm machine and I wanted to
> share a couple of small issues that I found in the process.
> - The meta-sdr/conf/bblayers.conf.sample doesn't include all the layers
> needed. This is correctly warned in the README file of the layer. I've
> attached the file that worked for me in case someone finds it useful.

You layer.conf file has loads of layers the dev image shouldn't need? Do
you know exactly which ones are missing? I'm setting the default for
meta-sdr so you can build demo image out of the box. The demo + video
layer recipe lists some additional layers you will need.

I didn't realize that the dependencies that I had missing were necessary for my target machine, but not required for meta-sdr, sorry. I've checked the dependencies with "bitbake -g gnuradio-demo-image" and the ones in bblayers.conf.sample are correct. The only thing I would suggest is to replace meta-oe for meta-openembedded as recommended in their github.


> - A couple of the layers include recipe.bbappend files for recipes that
> have been updated recently. I solved this ignoring them with BBMASK as you
> can see in the bblayers.conf file.
> - valgrind recipe failed. This seem to be a problem with the Yocto master
> branch so I deleted it from the recipes and I built without it.
> - volk failed to compile for qemuarm machine. I couldn't work around this
> one. I've attached the log file. Some of the recipes, including
> gnuradio_git depend on it so I don't think I'll be able to ignore it.
> The only real issue is the last one. It would be great to be able to
> compile for qemuarm. Could anyone give me a pointer to fix this? My machine
> runs Ubuntu 12.04 32 bit and the master branch for all the BSPs.
> Thanks,
> Murray
> _______________________________________________
> Discuss-gnuradio mailing list
> address@hidden
> https://lists.gnu.org/mailman/listinfo/discuss-gnuradio

reply via email to

[Prev in Thread] Current Thread [Next in Thread]