[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

(no subject)

From: Andreas Hoeschler
Subject: (no subject)
Date: Sat, 27 Apr 2002 22:47:46 +0200


I try to build GNUstep on Solaris 8. When I configure base I get the following:

bash-2.03# ./configure
loading cache ./config.cache
checking host system type... sparc-sun-solaris2.8
checking target system type... sparc-sun-solaris2.8
checking build system type... sparc-sun-solaris2.8
checking for gcc... gcc
checking whether the C compiler (gcc  ) works... yes
checking whether the C compiler (gcc  ) is a cross-compiler... no
checking whether we are using GNU C... yes
checking whether gcc accepts -g... yes
checking how to run the C preprocessor... gcc -E
checking for whoami... /usr/ucb/whoami
checking for Cygwin environment... no
checking for mingw32 environment... no
checking for executable suffix... no
checking whether nested functions work... yes
checking the Objective-C runtime... GNU
checking for objc/objc.h... yes
checking for gdomap network details... checking for variable length socket addresses... not found
checking whether SO_REUSADDR is broken...
The SO_REUSEADDR socket option for controlling re-use of network
sockets immediately after shutdown appears to be broken on this
machine.  Networking code will be built without using this
The effect of this lack is that when a network service is shut
down, it cannot be re-started on the same network port until
an operating-system timeout has expired.
For servers other than gdomap, GNUstep does not normally need
a particular network port, so the problem is unlikely to arise.
checking for objc threading flags...
checking whether byte ordering is bigendian... yes
checking size of void*... 4
checking size of short... 2
checking size of int... 4
checking size of long... 4
checking size of long long... 8
checking size of float... 4
checking size of double... 8
checking loading of constructor functions... yes
checking for dlfcn.h... yes
checking whether objc really works... no
I don't seem to be able to use your Objective-C compiler to produce
working binaries!  Please check your Objective-C compiler installation.
If you are using gcc-3.x make sure that your compiler's libgcc_s and libobjc
can be found by the dynamic linker - usually that requires you to play
with LD_LIBRARY_PATH or /etc/ld.so.conf.
Please refer to your compiler installation instructions for more help.
configure: error: The Objective-C compiler doesn't work or is not installed properly.

What is wrong here? I built 3.0.4 (wth objc part) from source. However, it seems a library could not be found. How can I fix this? ldconfig does not exist on Solaris. I tried

bash-2.03# LD_LIBRARY_PATH=$LD_LIBRARY_PATH:/usr/local/lib
bash-2.03# echo $LD_LIBRARY_PATH

and then rerun ./configure but with the same result.

Thanks a lot,


reply via email to

[Prev in Thread] Current Thread [Next in Thread]