discuss-gnustep
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Help with building requested


From: Richard Frith-Macdonald
Subject: Re: Help with building requested
Date: Mon, 9 Sep 2002 16:41:09 +0100

On Monday, September 9, 2002, at 04:28 PM, René Berber wrote:

On 2002-09-09 09:45:05 +0000 Blacktiger <address@hidden> wrote:

When trying to build gnustep-base-1.4.1 I get the following errors:
dllwrap: gcc exited with status 1
make[2]: *** [shared_obj/ix86/cygwin/gnu-gnu-gnu/gnustep-base.dll] Error 1
make[1]: *** [libgnustep-base.all.library.variables] Error 2
make[1]: Leaving directory
`/home/Blacktiger/gnustep/gnustep-base-1.4.1/Source'
make: *** [internal-all] Error 2

If I continue anyway and try to build gnustep-gui-0.8.0 I get this:
make[2]: *** [shared_obj/ix86/cygwin/gnu-gnu-gnu/Functions.o] Error 1
make[1]: *** [libgnustep-gui.all.library.variables] Error 2
make[1]: Leaving directory `/home/Blacktiger/gnustep/gnustep-
gui-0.8.0/Source'
make: *** [internal-all] Error 2

Anyone have any idea what I am doing wrong? I am using the latest version of
cygwin to do this, and the latest version of the gcc compiler.

Unless something changed recently, GNUstep doesn't compile with Cygwin, not even if you have built a newer gcc with ObjectiveC. The error you run into are exactly what you describe, dlltool is called with missing parameters, then, after using dlltool manually to create the library dllwraper complains with something similar.

There is some guide that describes how to build GNUstep with MinGW and how to cross-compile with Cygwin (it's in the README.* files inside the Documentation of gnustep-make) but I haven't tried.

Haven't tried it with the latest mingw/msys and gcc ... it worked with the versions as documented
a few weeks ago.
I don't know if anyone is trying to build using cygwin at present.





reply via email to

[Prev in Thread] Current Thread [Next in Thread]