discuss-gnustep
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: GNUstep newbie installation problem


From: Tom Koelman
Subject: Re: GNUstep newbie installation problem
Date: Tue, 17 Dec 2002 08:57:53 +0100

Lloyd Dupont <address@hidden> writes:

> I just donwnloaded ffcall-1.8d, gnustep-make-1.5.1,
> gnustep-base-1.5.1
>
> I have w2000, MinGW 2.0.0.3, gcc 3.2
> I did
> ./configure
> make
> make install
>
> for ffcall, gnustep-make,
> the . /......../GNUstep.sh
>
> the
> ./configure
> make
> for gnustep-base
>
> and it failed...
> at the end, while trying to link every one,
> here are the last few lines:
> //--------------------
>  Linking library libgnustep-base ...
> gnustep-base.exp(.edata+0x514):fake: undefined
> reference to `__objc_class_name_GSFFCallInvocation'
> D:\MinGW\bin\dllwrap.exe: gcc exited with status 1
> make[2]: ***
> [shared_obj/ix86/mingw32/gnu-gnu-gnu/gnustep-base.dll]
> Error 1
> make[1]: *** [libgnustep-base.all.library.variables]
> Error 2
> make[1]: Leaving directory
> `/d/GNUstep/gnustep-base-1.5.1/Source'
> make: *** [internal-all] Error 2
> //------------------------------

Did you do 

./configure --prefix=$GNUSTEP_SYSTEM_ROOT 
--includedir=$GNUSTEP_SYSTEM_ROOT/Headers

for ffcall?

> Also, I wondered, I didn't install gnustep-libobjc as
> I have gcc 3.2. But in MinGW, all what I see about
> ObjectiveC is libobjc.a (a static library !)
> so it is not a problem to use foundation as DLL, while
> the runtime is statically linked ?

>From README.MinGW:

Despite the statement in the GNUstep-HOWTO, even if you have a 3.x
compiler, you still need to install gnustep-objc as it properly
exports symbols for DLLs.

Tom
>From address@hidden Tue Dec 17 04:41:37 2002
Received: from list by monty-python.gnu.org with tmda-scanned (Exim 4.10.13)
        id 18OEEK-000112-00
        for address@hidden; Tue, 17 Dec 2002 04:41:36 -0500
Received: from mail by monty-python.gnu.org with spam-scanned (Exim 4.10.13)
        id 18OEEG-0000x1-00
        for address@hidden; Tue, 17 Dec 2002 04:41:33 -0500
Received: from tomts22.bellnexxia.net ([209.226.175.184]
        helo=tomts22-srv.bellnexxia.net)
        by monty-python.gnu.org with esmtp (Exim 4.10.13)       id 
18OEEF-0000vF-00
        for address@hidden; Tue, 17 Dec 2002 04:41:31 -0500
Received: from jay ([64.229.182.155]) by tomts22-srv.bellnexxia.net
          (InterMail vM.5.01.04.19 201-253-122-122-119-20020516) with ESMTP
          id <address@hidden>
          for <address@hidden>; Tue, 17 Dec 2002 04:41:31 -0500
From: Mike Reid <address@hidden>
To: GNUstep discussion <address@hidden>
Content-Type: text/plain
Content-Transfer-Encoding: 7bit
X-Mailer: Ximian Evolution 1.0.8 (1.0.8-10) 
Date: 17 Dec 2002 04:41:54 -0500
Message-Id: <address@hidden>
Mime-Version: 1.0
Subject: gpbs, font_cacher problems.
X-BeenThere: address@hidden
X-Mailman-Version: 2.1b5
Precedence: list
List-Id: Discussion list for the GNUstep programming environment
 <discuss-gnustep.gnu.org>
List-Help: <mailto:address@hidden>
List-Post: <mailto:address@hidden>
List-Subscribe: <http://mail.gnu.org/mailman/listinfo/discuss-gnustep>,
        <mailto:address@hidden>
List-Archive: <http://mail.gnu.org/pipermail/discuss-gnustep>
List-Unsubscribe: <http://mail.gnu.org/mailman/listinfo/discuss-gnustep>,
        <mailto:address@hidden>
X-List-Received-Date: Tue, 17 Dec 2002 09:41:38 -0000

Hello,

I'm hoping someone has some info about these two tools in the GNUstep
core. For some reason I can't either of them to work.

I first tried the stable packages, things compiled and installed. I used
the defaults (ie. ffcall1.8d, install to /usr/GNUstep, the xlib
backend). Everything seemed to be working, but the gpbs server wouldn't
startup. I'd run it, it'd load for a second, and then the error
"Aborted" appears on the console and the program terminates.  Both
gdomap and gdnc work fine, and I am running X when I do this. For the
stable version of GNUstep font_cacher worked.

Hoping the problem was solved in a later version I downloaded Dec. 16
snapshots of the core, uninstalled the stable versions, installed the
updated, and tried gpbs. It just seems to hang there forever.. I run the
program and it never returns me to the prompt. I can kill it fine and my
system doesn't become unstable but it refuses to give me any feedback at
all. Even using the --no-fork, or even --help produces no output and
still seems to hang. In this new version font_cacher has the same
behaviour as gpbs, neither of the two programs work at all.

This is getting long, but one last bit of info I picked up: 
I tried compiling debugging symbols into both tools, and then using gdb
5.2.1 (without the objc patch) to find out where its halting. But I
can't get gdb to give me any info either. I put a breakpoint at the
start of main. Doesn't seem to hit it, I tried breaking on
__libc6_startup (not too sure thats the right name), nothing.

So, has anything experienced anything like this? Any info is
appreciated. 

-Mike Reid




reply via email to

[Prev in Thread] Current Thread [Next in Thread]