[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Renaissance menus on OS X ?

From: Helge Hess
Subject: Re: Renaissance menus on OS X ?
Date: Fri, 17 Jan 2003 11:34:58 +0100
User-agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3b) Gecko/20030108

Nicola Pero wrote:
"class" should be used for CSS ;-) But besides that, yes, IMHO this would be correct (MyWindow class used in a window "mapping" context).

After thinking quite a lot about it, I changed the name of the attribute
from 'class' to 'instanceOf' (I implemented all this stuff in the
meanwhile).  It leaves 'class' to be maybe used for any sort of future
CSS-related technology, and it avoids people getting confused and thinking
that this attribute works in the same way as it does in CSS.

So the example is now -

<window instanceOf="MyWindow" title="Hello" width="200" height="4000">
   <!-- some views here -->

Since I'm always only complaining I won't stop over a small, absolutely unimportant detail ;-)

To make it more XML-like I would name the attribute "instance-of" instead of "instanceOf". This is the usual naming practice in XML based languages.
On the other side, it doesn't really matter anyway ;-)

Helge Hess                         Email:    address@hidden
SKYRIX Software AG                 Tel:      +49-391-6623-0
Universitaetsplatz 12              Fax:      +49-391-6623-599
39104 Magdeburg, Germany           Internet: http://www.skyrix.com
Upgrade your SLEMS 3.x:              http://www.skyrix.de/de/news/

reply via email to

[Prev in Thread] Current Thread [Next in Thread]