discuss-gnustep
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Building gnustep-gui-0.8.4 on RedHat 8.0


From: Willem Rein Oudshoorn
Subject: Re: Building gnustep-gui-0.8.4 on RedHat 8.0
Date: 16 Mar 2003 22:23:26 +0100
User-agent: Gnus/5.09 (Gnus v5.9.0) Emacs/21.2

Jean-Fran├žois Rouanet <address@hidden> writes:

> Hello,
> I am trying to install gnustep on Linux RedHat 8.0 and the build of
> gnustep-gui-0.8.4 failed with this error message. I have tried with
> the tar.gz and with the src rpm and I got the same result:
> 
> 
> shared_obj/ix86/linux-gnu/gnu-gnu-gnu/portaudio/pa_unix_oss/pa_unix_oss.o(.text+0x12e4):
> undefined reference to `pthread_create'
> shared_obj/ix86/linux-gnu/gnu-gnu-gnu/portaudio/pa_unix_oss/pa_unix_oss.o:
> In function `PaHost_StopEngine':
> shared_obj/ix86/linux-gnu/gnu-gnu-gnu/portaudio/pa_unix_oss/pa_unix_oss.o(.text+0x13b0):
> undefined reference to `pthread_join'
> collect2: ld returned 1 exit status
> make[3]: *** [shared_obj/ix86/linux-gnu/gnu-gnu-gnu/gnustep_sndd] Error 1
> make[2]: *** [gnustep_sndd.all.tool.variables] Error 2
> make[2]: Leaving directory
> `/usr/src/redhat/BUILD/gnustep-gui-0.8.4/Tools/gsnd'
> make[1]: *** [internal-all] Error 2
> make[1]: Leaving directory `/usr/src/redhat/BUILD/gnustep-gui-0.8.4/Tools'
> make: *** [internal-all] Error 2
> error: Bad exit status from /var/tmp/rpm-tmp.43892 (%build)

Seems like the runtime was configured without thread support.

Can you look in the file:

$GNUSTEP_MAKEFILES/ix86/linux-gnu/config.make

(Or if you are not using replace ix86 with something appropriate)

if you find any references to threading?

Wim Oudshoorn.





reply via email to

[Prev in Thread] Current Thread [Next in Thread]