discuss-gnustep
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Problem with NSProcessInfo (?)


From: Yen-Ju Chen
Subject: Re: Problem with NSProcessInfo (?)
Date: Tue, 20 May 2003 14:15:37 -0400


 I do have something similiar to this problem,
 but may not be relevant.
 When I try to load GNUstep library from Ruby environment,
 it always segment fault if there is any ObjC code
 in the loading funcation Init_moduleName(),
 which I think is similiar to +load in this case.
 The behavior is the same,
 either empty or pure C code is O.K., but not ObjC.
 Since it involves Ruby (C-language) and GNUstep (ObjC),
 I just think it is too hard for me to trace it down.
 And some testing shows there is no problem
 by calling ObjC from C runction.
 So I just work around it.

 Just my little experience.

 Yen-Ju


From: "Chris B. Vetter" <address@hidden>
To: address@hidden
CC: address@hidden
Subject: Re: Problem with NSProcessInfo (?)
Date: Tue, 20 May 2003 10:18:03 -0700


I've played around a bit (using gcc32, no gcc33 here), if +load
- is completely empty, it works
- only has plain C code, it works
- has any kind of ObjC code, even a simple NSLog(@"foo"), it fails.

--
Chris


_______________________________________________
Discuss-gnustep mailing list
address@hidden
http://mail.gnu.org/mailman/listinfo/discuss-gnustep

_________________________________________________________________
The new MSN 8: smart spam protection and 2 months FREE* http://join.msn.com/?page=features/junkmail





reply via email to

[Prev in Thread] Current Thread [Next in Thread]