discuss-gnustep
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

RE: Problems with Objc Runtime and Foundation Classes


From: S.B., Vaitheeswaran
Subject: RE: Problems with Objc Runtime and Foundation Classes
Date: Tue, 17 Jun 2003 13:24:04 -0700

Yes, removed previous installation completely and tried to install. I
have windows 2000 installed. This really driving me crazy. Also, earlier
I followed each and every step given in readme.mingw, but some of the
stuff that they say doesn't work so I had to try different combination
to get all the packages built and installed. For example, to install
FFCALL they say we have to do the following
"
./configure --prefix=$GNUSTEP_SYSTEM_ROOT \
 --libdir=$GNUSTEP_SYSTEM_ROOT/Libraries/ix86/mingw32 \
 --includedir=$GNUSTEP_SYSTEM_ROOT/Headers
make
make install
"

but in reality this is what works,
"
./configure 
make
make install
"

thanks,
Vaithee.

in the former "make install" fails saying that the path is not
absolutely.


-----Original Message-----
From: Adam Fedor [mailto:address@hidden
Sent: Tuesday, June 17, 2003 1:16 PM
To: S.B., Vaitheeswaran
Cc: Tom Koelman
Subject: Re: Problems with Objc Runtime and Foundation Classes


Looks like something wrong with mingw. Are you sure you removed all 
traces of any previous mingw installation, etc?  What version of 
Windows do you have?

On Tuesday, June 17, 2003, at 12:04 PM, S.B., Vaitheeswaran wrote:

> Hi,
> I am trying to use the windows intaller version of GNUStep and getting
> into trouble. Please find attached the file installer.tar.bz2 file to
> this email and help me.
>
> Vaithee.
>
> -----Original Message-----
> From: Adam Fedor [mailto:address@hidden
> Sent: Monday, June 16, 2003 7:23 PM
> To: S.B., Vaitheeswaran
> Cc: address@hidden
> Subject: Re: Problems with Objc Runtime and Foundation Classes
>
>
>
>
> S.B., Vaitheeswaran wrote:
>> Hi all,
>>      I am pretty new to GNUStep and Obj-c. Recently, I managed to get
>> Objc and GnuStep installed under mingw. I am able to compile and run
>> simple obj-c code without any problem. But when I try to use the
> GNUStep
>> foundation classes like NSObject or NSString I get into trouble. I am
>> trying to compile a small piece of code that uses NSString using the
>> make framework provided by Gnustep and also am successfull. But when
I
>
>> run the program I get the following problem,
>>
>> "
>> $ static_obj/ix86/mingw32/gnu-gnu-gnu/m.exe
>>
>> abnormal program termination
>> objc runtime: cannot find class NSString
>> "
>> I have tried both shared(make) and static(make shared=no) linking but
>> still have the same problem. I would like to get some pointers in
this
>
>> regard.
>>
>
> How did you install GNUstep? Using the README.MinGW in
> gnustep-make/Documentation or using the windows installer
> (ftp://ftp.gnustep.org/pub/gnustep/windows)? If you used the README
you
> need to follow the instructions exactly. Sometimes even installing a
> non-GNUstep library that has been compiled badly will cause these
types
> of problem (very frustrating to track down as well).
>
> I'd recommend trying the installer if you haven't done so.
>
> <installer.tar.bz2>





reply via email to

[Prev in Thread] Current Thread [Next in Thread]