discuss-gnustep
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Q] Font Display problem again...(art backend)


From: NeXT
Subject: Re: [Q] Font Display problem again...(art backend)
Date: Wed, 29 Oct 2003 11:55:49 +0900

Thanks for reply, BTW, is this patch related to my problem? If so, why the demo program displays string correctly? From my point of view, it seems that positioning of glyph in GNUstep is somewhat wrong...

Thanks again.

On 2003-10-29 10:44:10 +0900 Alexander Malmberg <address@hidden> wrote:

NeXT wrote:
I'm using most current version of CVS and using 2.1.4 of
freetype(freetype2).

For 2.1.4, you'll probably want this patch:

http://w1.423.telia.com/~u42308495/alex/ftlru.c.diff

(Note that it's a patch for freetype.)

I just started to look at the ft2demo code
for displaying strings. What part should I refer in back ?

Source/art/ftfont.m. The main method is -drawGlyphs:..., so if you just
want to compare, look at that one.

However, it needs to be consistent with several other methods, and the
whole thing really needs to be cleaned up. It works, but making changes
is hard.

Is there
any good documentation on freetype

In the freetype package, or a freetype-docs package. Freetype has decent
documentation.

and libart ?

None that I know of. libart isn't involved in this, though.

- Alexander Malmberg


_______________________________________________
Discuss-gnustep mailing list
address@hidden
http://mail.gnu.org/mailman/listinfo/discuss-gnustep






reply via email to

[Prev in Thread] Current Thread [Next in Thread]