[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: GNUstep on Darwin!

From: Andrew Pinski
Subject: Re: GNUstep on Darwin!
Date: Mon, 24 Nov 2003 00:28:49 -0800

On Nov 24, 2003, at 00:06, John Davidorff Pell wrote:

I can't help but I am curious (can't help it either)

Like which version of gcc are you using and on
which Darwin version ... I did not get lucky
at building gcc with gnu-objc

gcc-3.2.2 stopped somewhere because of some constant macro expression
and Apple's gcc-3.3 did not build libobjc even though I passed
--enable-libojc and patched config/darwin.h

You will never get gcc to build its own libobjc on darwin, some MOTHER FUCKER at Apple patched the FSF sources (in FSF cvs, not Apple CVS) so that it would never build on darwin. If you look in the archives for the gcc mailing list you might find it, i remember reading about it.

I am using Apple's gcc, Panther edition. (3.3)


P.S. Pardon my french, I'm still a little peeved...

You better be because that person is a global maintainer on GCC and
he thought he was doing right, I have asked to take over maintainer
of libobjc in GCC and everyone has been supported but no action has
come out of it.

The first thing, I will do is make sure that GNU's libobjc is able to run on Darwin and reable it as an option and able to say -fgnu-runtime and also get
the GNU runtime.

Andrew Pinski

reply via email to

[Prev in Thread] Current Thread [Next in Thread]