[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: NSProcessInfo is not initialized when debugging

From: Martin Kuball
Subject: Re: NSProcessInfo is not initialized when debugging
Date: Sat, 22 May 2004 12:23:19 +0200
User-agent: KMail/1.6.2

From what I understood the problem is not with gnustep-base1-dbg or 
gnustep-gui0-dbg but with the gnustep-back package. This is not a lib 
but a bundle and there is not even a debug version in debian. 
So for now I guess I have to compile my own version of the back 
package with debug info. 
Maybe a real solution would be to make the bundleName in NSApplication 
depend on the gui lib mode. I mean use ibgnustep-back.bundle for non 
debug version and e.g. ibgnustep-back-dbg.bundle for the debug 


Am Friday 21 May 2004 16:38 schrieb Eric Heintzmann:
> Adam Fedor wrote:
> > On May 21, 2004, at 1:22 AM, Richard Frith-Macdonald wrote:
> >> Ah ... I misunderstood ... I use GNUstep built from source
> >> rather than the debian packages.
> >>
> >> I don't know how you can get an app linked with both debug and
> >> non-debug libraries, but
> >> I can see that it could cause problems if one version of
> >> NSProcessInfo gets initialised and
> >> somehow another version from a different library then gets used
> >> (uninitialised).
> >>
> >> Is one of the debug libraries (eg the gui library) linked with a
> >> non-debug version of the
> >> base library?  Perhaps when the debian package was built the
> >> maintainer did it in the
> >> wrong order, so that  the debug gui library was linked with the
> >> non-debug  base library
> >> because the debug version of the base library hadn't yet been
> >> built/installed?
> >
> > Another poster had this problem a month or two ago - it turned
> > out to be related to bundles and/or frameworks. In GNUstep, debug
> > and non-debug bundles and frameworks can't coexist. so it's
> > possible to link a framework that is linked to the non-debug
> > version of base into a debug version of an app.  I hope there is
> > some way we can fix that.
> Does it mean, on a debian way, that framework packages should
> conflict with gnustep-base1-dbg and gnustep-gui0-dbg ? (to make
> sure debug version of theses libraries won't be linked)
> And at run time, can gnustep-base1-dbg and gnustep-gui0-dbg be
> present ?

reply via email to

[Prev in Thread] Current Thread [Next in Thread]