discuss-gnustep
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Q] Error in building the gnustep-base


From: Richard Frith-Macdonald
Subject: Re: [Q] Error in building the gnustep-base
Date: Mon, 21 Mar 2005 18:36:50 +0000

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

On 2005-03-21 08:57:44 +0000 JongAm Park <address@hidden> wrote:

Hello.

I am trying to build the gnustep-base 1.8.0 version on cygwin.
I installed xml2.
It fails in linking with these messages.

info : resolving _htmlDefaultSAXHandler by linking to __imp_htmlDefaultSAXHandler ( auto-import )
info: resolving _xmlFree by linking to __imp__xmlFree (auto-import)
info: resolving _xmlDefaultSAXHandler by linking to __imp__xmlDefaultSAXHandler (auto-import) info: resolving _xmlGetWarningsDefaultValue by linking to __imp__xmlGetWarningsDefaultValue (auto-import)

and so on.

Could someone help me to solve these problems?
I have no idea what is wrong with this. Probably due to the changes of the functions, it may not find the proper functions in link time.

There are problems with linking libraries on windows, depending on how the
libraries were built.  I am not aware of any pre-built version of libxml2
available for windows which works with other code built by the gcc compiler
the way gnustep is.

You can configure the base librarry with the --disable-xml option to work
around the problem (though of course that means no xml support).  Your other
option may be to build libxml2 yourself, from source and using the same
compiler that you use to build gnustep-base.  I haven't tried that myself,
but I've heard reports that it works.
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.2.5 (GNU/Linux)
Comment: Using the GPG bundle for GNUMail

iD8DBQFCPxRCE6AJp3nmKIkRAs7bAKDLziX6DKXen0s3wSvsFicQJ0MkUwCg3oWP
iojiQNUnOBmoew8w2YlsQWQ=
=+xBC
-----END PGP SIGNATURE-----





reply via email to

[Prev in Thread] Current Thread [Next in Thread]