discuss-gnustep
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Gorm & Camaelon


From: Gregory John Casamento
Subject: Re: Gorm & Camaelon
Date: Tue, 22 Mar 2005 04:37:49 -0800 (PST)

Georgios,

Do the following:

defaults write Gorm AllowUserBundles YES

You'll still get the warning, but Gorm will not quit.   Alternatively you can
do this:

defaults write Gorm GSAppKitUserBundles "()" to prevent bundles from being
loaded into Gorm at all.

Later, GJC

--- Georgios Fourtounis <address@hidden> wrote:
> Hi list, this is my first post, congrats to all for GNUstep!
> I am now learning Gorm and the following happens:
> - openapp Gorm
> - it says "Gorm has detected that you are using user bundles. Please
> make certain that these are compatible with Gorm as some bundles can
> cause issues which may corrupt your .gorm files." in a "User bundle
> warning" box
> - a box "Illegal Class Substitution" appears saying "A bundle has
> invoked 'poseAsClass:', this could corrupt .gorm files. Quitting.".
> - Gorm quits
> This has started happening since the install of Camaelon, which uses the
> posaAsClass mechanism to substitue the GUI if I remember correctly.
> Disabling the Camaelon theme(=putting an invalid path for it in the
> .GNUstepDefaults) results in the first message only and then Gorm loads
> fine.
> What can be done about it? Is there a flag to tell Gorm to ignore this
> or is it a Camaelon problem?
> Googling around doesn't produce anything for that error.
> I am running GNUstep from some days CVS (except for -gui which is a week
> older but that should be irrelevant).
> 
> Cheers,
> George
> 
> 
> 
> _______________________________________________
> Discuss-gnustep mailing list
> address@hidden
> http://lists.gnu.org/mailman/listinfo/discuss-gnustep
> 

Gregory John Casamento 
-- CEO/President Open Logic Corp. (A MD Corp.)
## Maintainer of Gorm (IB Equiv.) for GNUstep.




reply via email to

[Prev in Thread] Current Thread [Next in Thread]